gnu: python-feedparser: Add Python >=3.9 compatibility.

* gnu/packages/patches/python-feedparser-missing-import.patch: New file.
* gnu/local.mk: Add it.
* gnu/packages/web.scm (python-feedparser): Use it.
This commit is contained in:
Lars-Dominik Braun 2023-03-18 09:50:56 +01:00
parent cfccd6fe5a
commit f9bff8614b
No known key found for this signature in database
GPG Key ID: F663943E08D8092A
3 changed files with 37 additions and 1 deletions

View File

@ -1636,6 +1636,7 @@ dist_patch_DATA = \
%D%/packages/patches/ppsspp-disable-upgrade-and-gold.patch \
%D%/packages/patches/pthreadpool-system-libraries.patch \
%D%/packages/patches/python-chai-drop-python2.patch \
%D%/packages/patches/python-feedparser-missing-import.patch \
%D%/packages/patches/python-louvain-fix-test.patch \
%D%/packages/patches/python-random2-getrandbits-test.patch \
%D%/packages/patches/python-poppler-qt5-fix-build.patch \

View File

@ -0,0 +1,34 @@
Since feedparser messes with Pythons internals by assigning
to __code__ it needs to import SGMLParseError too. It also
expects SGMLParseError, which was turned into AssertionError by
https://github.com/python/cpython/commit/e34bbfd61f405eef89e8aa50672b0b25022de320
--- feedparser-6.0.10/feedparser/sgml.py.orig 2023-03-18 09:24:50.976316932 +0100
+++ feedparser-6.0.10/feedparser/sgml.py 2023-03-18 09:26:32.971928811 +0100
@@ -28,6 +28,7 @@
import re
import sgmllib
+from sgmllib import SGMLParseError
__all__ = [
'sgmllib',
@@ -41,6 +42,7 @@
'shorttagopen',
'starttagopen',
'endbracket',
+ 'SGMLParseError',
]
# sgmllib defines a number of module-level regular expressions that are
--- feedparser-6.0.10/feedparser/html.py.orig 2023-03-18 09:32:03.647114745 +0100
+++ feedparser-6.0.10/feedparser/html.py 2023-03-18 09:46:05.021142671 +0100
@@ -349,7 +349,7 @@
try:
return sgmllib.SGMLParser.parse_declaration(self, i)
- except sgmllib.SGMLParseError:
+ except AssertionError:
# Escape the doctype declaration and continue parsing.
self.handle_data('<')
return i+1

View File

@ -4750,7 +4750,8 @@ their web site.")
(method url-fetch)
(uri (pypi-uri "feedparser" version ".tar.gz"))
(sha256
(base32 "0lfa1c8s6abnlksbwxdpq78bg4rb6603mcgarmip3kip8rglini7"))))
(base32 "0lfa1c8s6abnlksbwxdpq78bg4rb6603mcgarmip3kip8rglini7"))
(patches (search-patches "python-feedparser-missing-import.patch"))))
(build-system python-build-system)
(propagated-inputs
(list python-sgmllib3k))