gnu: tcl, tk: Update to 8.6.7.

* gnu/packages/tcl.scm (tcl): Update to 8.6.7.
[source]: Remove obsolete patch.
(tk): Update to 8.6.7.
* gnu/packages/patches/tcl-mkindex-deterministic.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
Marius Bakke 2017-12-13 07:26:42 +01:00
parent 971af38c89
commit f7c03e452b
No known key found for this signature in database
GPG key ID: A2A06DF2A33A54FA
3 changed files with 4 additions and 35 deletions

View file

@ -1055,7 +1055,6 @@ dist_patch_DATA = \
%D%/packages/patches/t1lib-CVE-2011-1552+CVE-2011-1553+CVE-2011-1554.patch \
%D%/packages/patches/tar-CVE-2016-6321.patch \
%D%/packages/patches/tar-skip-unreliable-tests.patch \
%D%/packages/patches/tcl-mkindex-deterministic.patch \
%D%/packages/patches/tclxml-3.2-install.patch \
%D%/packages/patches/tcsh-fix-autotest.patch \
%D%/packages/patches/tcsh-fix-out-of-bounds-read.patch \

View file

@ -1,29 +0,0 @@
This patch ensures that the 'tclIndex' files generated by 'auto_mkindex'
are sorted in a deterministic fashion.
Fixes a non-determinism issue reported
at <https://lists.gnu.org/archive/html/guix-devel/2015-10/msg00696.html>.
--- tcl8.6.4/library/auto.tcl 2015-02-26 17:57:28.000000000 +0100
+++ tcl8.6.4/library/auto.tcl 2015-11-13 23:18:34.964831717 +0100
@@ -207,6 +207,9 @@ proc auto_mkindex {dir args} {
set args *.tcl
}
+ # Keep file names sorted in a determistic order.
+ set args [lsort -ascii $args]
+
auto_mkindex_parser::init
foreach file [glob -- {*}$args] {
try {
@@ -241,6 +244,10 @@ proc auto_mkindex_old {dir args} {
if {![llength $args]} {
set args *.tcl
}
+
+ # Keep file names sorted in a determistic order.
+ set args [lsort -ascii $args]
+
foreach file [glob -- {*}$args] {
set f ""
set error [catch {

View file

@ -38,15 +38,14 @@ (define-module (gnu packages tcl)
(define-public tcl
(package
(name "tcl")
(version "8.6.6")
(version "8.6.7")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/tcl/Tcl/"
version "/tcl" version "-src.tar.gz"))
(sha256
(base32
"01zypqhy57wvh1ikk28bg733sk5kf4q568pq9v6fvcz4h6bl0rd2"))
(patches (search-patches "tcl-mkindex-deterministic.patch"))))
"19bb09l55alz4jb38961ikd5116q80s51bjvzqy44ckkwf28ysvw"))))
(build-system gnu-build-system)
(arguments
'(#:phases (alist-cons-before
@ -137,14 +136,14 @@ (define-public expect
(define-public tk
(package
(name "tk")
(version "8.6.6")
(version "8.6.7")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/tcl/Tcl/"
version "/tk" version "-src.tar.gz"))
(sha256
(base32
"17diivcfcwdhp4v5zi6j9nkxncccjqkivhp363c4wx5lf4d3fb6n"))
"1aipcf6qmbgi15av8yrpp2hx6vdwr684r6739p8cgdzrajiy4786"))
(patches (search-patches "tk-find-library.patch"))))
(build-system gnu-build-system)
(arguments