gnu: perl-tk: Patch for i686

* gnu/packages/patches/perl-tk-x11-discover.patch: New patch.
* gnu-system.am [dist_patch_DATA]: Add it.
* gnu/packages/tcl.scm (perl-tk)[origin]: Use it.
This commit is contained in:
Eric Bavier 2014-05-12 11:42:53 -05:00
parent ab6a279abb
commit f5ea273a00
3 changed files with 18 additions and 1 deletions

View File

@ -325,6 +325,7 @@ dist_patch_DATA = \
gnu/packages/patches/patchelf-page-size.patch \
gnu/packages/patches/patchutils-xfail-gendiff-tests.patch \
gnu/packages/patches/perl-no-sys-dirs.patch \
gnu/packages/patches/perl-tk-x11-discover.patch \
gnu/packages/patches/petsc-fix-threadcomm.patch \
gnu/packages/patches/plotutils-libpng-jmpbuf.patch \
gnu/packages/patches/procps-make-3.82.patch \

View File

@ -0,0 +1,14 @@
On non-x86_64 systems, this conditional can cause a specified X11 build value
to be overwritten to null, causing x11 discovery to fail.
--- a/myConfig 2014-05-12 11:16:48.152719722 -0500
+++ b/myConfig 2014-05-12 11:16:24.704719113 -0500
@@ -350,7 +350,7 @@
#
# Prefer 64bit libraries on certain architectures
#
- unless (defined $xlib and $Config{'archname'} =~ m/x86_64/)
+ unless (defined $xlib or not $Config{'archname'} =~ m/x86_64/)
{
$xlib64 = &lX11(0, chooseX11(</usr/X11*/lib64>));
}

View File

@ -23,6 +23,7 @@
#:use-module (guix download)
#:use-module (guix build-system gnu)
#:use-module (guix build-system perl)
#:use-module (gnu packages)
#:use-module (gnu packages libpng)
#:use-module (gnu packages libjpeg)
#:use-module (gnu packages perl)
@ -177,7 +178,8 @@ X11 GUIs.")
version ".tar.gz"))
(sha256
(base32
"0jarvplhfvnm0shhdm2a5zczlnk9mkf8jvfjiwyhjrr3cy1gl0w0"))))
"0jarvplhfvnm0shhdm2a5zczlnk9mkf8jvfjiwyhjrr3cy1gl0w0"))
(patches (list (search-patch "perl-tk-x11-discover.patch")))))
(build-system perl-build-system)
(native-inputs `(("pkg-config" ,pkg-config)))
(inputs `(("libx11" ,libx11)