gnu: python-ipython-documentation: Remove patches.

* gnu/packages/python-xyz.scm (python-ipython-documentation)[source]:
Remove upstreamed patches.
* gnu/packages/patches/python-ipython-documentation-chars.patch,
gnu/packages/patches/python-ipython-documentation-repro.patch:
Delete files.
* gnu/local.mk: Remove files.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
This commit is contained in:
Greg Hogan 2023-05-22 20:17:40 +00:00 committed by Ludovic Courtès
parent 53c47c4f28
commit f1af4fbeec
No known key found for this signature in database
GPG key ID: 090B11993D9AEBB5
4 changed files with 0 additions and 52 deletions

View file

@ -1786,8 +1786,6 @@ dist_patch_DATA = \
%D%/packages/patches/python-fixtures-remove-monkeypatch-test.patch \
%D%/packages/patches/python-hiredis-fix-header.patch \
%D%/packages/patches/python-hiredis-use-system-hiredis.patch \
%D%/packages/patches/python-ipython-documentation-chars.patch \
%D%/packages/patches/python-ipython-documentation-repro.patch \
%D%/packages/patches/python-keras-integration-test.patch \
%D%/packages/patches/python-pdoc3-tests.patch \
%D%/packages/patches/python-peachpy-determinism.patch \

View file

@ -1,18 +0,0 @@
Avoid LaTeX errors due to non-printable characters.
Submitted upstream: https://github.com/ipython/ipython/pull/13640
diff --git a/IPython/utils/coloransi.py b/IPython/utils/coloransi.py
index e33142180..9300b0108 100644
--- a/IPython/utils/coloransi.py
+++ b/IPython/utils/coloransi.py
@@ -74,8 +74,8 @@ class TermColors:
class InputTermColors:
"""Color escape sequences for input prompts.
- This class is similar to TermColors, but the escapes are wrapped in \001
- and \002 so that readline can properly know the length of each line and
+ This class is similar to TermColors, but the escapes are wrapped in \\001
+ and \\002 so that readline can properly know the length of each line and
can wrap lines accordingly. Use this class for any colored text which
needs to be used in input prompts, such as in calls to raw_input().

View file

@ -1,25 +0,0 @@
Fix non-reproducibilities caused by time-dependent procedures.
Submitted upstream: https://github.com/ipython/ipython/pull/13640
diff --git a/IPython/sphinxext/ipython_directive.py b/IPython/sphinxext/ipython_directive.py
index 18bdfcae9..2c665ac87 100644
--- a/IPython/sphinxext/ipython_directive.py
+++ b/IPython/sphinxext/ipython_directive.py
@@ -19,7 +19,7 @@
In [1]: 1+1
In [1]: import datetime
- ...: datetime.datetime.now()
+ ...: datetime.date.fromisoformat('2022-02-22')
It supports IPython construct that plain
Python does not understand (like magics):
@@ -28,7 +28,7 @@
In [0]: import time
- In [0]: %timeit time.sleep(0.05)
+ In [0]: %pdoc time
This will also support top-level async when using IPython 7.0+

View file

@ -10457,13 +10457,6 @@ (define-public python-ipython-documentation
(inherit python-ipython)
(name "python-ipython-documentation")
(version (package-version python-ipython))
(source
(origin
(inherit (package-source python-ipython))
(patches (append (search-patches
"python-ipython-documentation-chars.patch"
"python-ipython-documentation-repro.patch")
(origin-patches (package-source python-ipython))))))
(arguments
(list
#:phases