gnu: emacs-libgit: Update to 0.0.1-1.ab1a53a.

* gnu/packages/emacs-xyz.scm (emacs-libgit): Update to 0.0.1-1.ab1a53a.
[source]<origin>: Remove unnecessary patch.
[arguments]: Skip failing tests.
[license]: Set to GPL2+.
* gnu/packages/patches/emacs-libgit-use-system-libgit2.patch: Delete file.
* gnu/local.mk: Apply file deletion.
This commit is contained in:
Nicolas Goaziou 2023-01-29 21:43:58 +01:00
parent 3e8dd0df8c
commit f0ff03069d
No known key found for this signature in database
GPG key ID: DA00B4F048E92F2D
3 changed files with 10 additions and 97 deletions

View file

@ -1066,7 +1066,6 @@ dist_patch_DATA = \
%D%/packages/patches/emacs-json-reformat-fix-tests.patch \
%D%/packages/patches/emacs-helpful-fix-docstring-test.patch \
%D%/packages/patches/emacs-highlight-stages-add-gexp.patch \
%D%/packages/patches/emacs-libgit-use-system-libgit2.patch \
%D%/packages/patches/emacs-lispy-fix-thread-last-test.patch \
%D%/packages/patches/emacs-native-comp-driver-options.patch \
%D%/packages/patches/emacs-polymode-fix-lexical-variable-error.patch \

View file

@ -1081,11 +1081,11 @@ (define-public emacs-with-editor
(license license:gpl3+)))
(define-public emacs-libgit
(let ((commit "0ef8b13aef011a98b7da756e4f1ce3bb18e4d55a")
(let ((commit "ab1a53a6a0120872e42582fc980e779d47de6d0e")
(revision "1"))
(package
(name "emacs-libgit")
(version (git-version "20200515" revision commit))
(version (git-version "0.0.1" revision commit))
(source (origin
(method git-fetch)
(uri (git-reference
@ -1094,11 +1094,7 @@ (define-public emacs-libgit
(file-name (git-file-name name version))
(sha256
(base32
"0pnjr3bg6y6354dfjjxfj0g51swzgl1fncpprah75x4k94rd369f"))
(patches (search-patches
;; Submitted for inclusion upstream (see:
;; https://github.com/magit/libegit2/pull/96).
"emacs-libgit-use-system-libgit2.patch"))
"1fqqhc7mr9lyshqva8wqknk5kc9vr10rxdp9dkrqgwawr3lk1k5p"))
(snippet
#~(begin
;; bundled, use the one shipped with emacs instead
@ -1131,6 +1127,12 @@ (define-public emacs-libgit
(emacs-substitute-variables "libgit.el"
("libgit--module-file"
(string-append (emacs:elpa-directory out) "/libegit2.so"))))))
(add-after 'unpack 'skip-failing-tests
;; XXX: Skip 2 failing tests (out of 29).
(lambda _
(substitute* "test/submodule-test.el"
(("\\(ert-deftest (status|ids) .*" all)
(string-append all " (skip-unless nil)")))))
(add-before 'install 'prepare-for-install
(lambda _
(let ((s "../source"))
@ -1163,7 +1165,7 @@ (define-public emacs-libgit
(description "This is an experimental module written in C providing
libgit2 bindings for Emacs, intended to boost the performance of Magit.")
;; The LICENSE file says GPL v2+, but libgit.el says GPL v3+.
(license license:gpl3+))))
(license license:gpl2+))))
(define-public emacs-magit
(let ((commit "c883fabe28a74d59d996cbef3f742874f3459bc0")

View file

@ -1,88 +0,0 @@
From de3c48d72ec7064e7f0522877fe759c729df0c50 Mon Sep 17 00:00:00 2001
From: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Date: Wed, 25 Mar 2020 11:32:18 -0400
Subject: [PATCH] Allow using a system provided libgit2 library
Setting the USE_SYSTEM_LIBGIT2 Make or CMake variable (through the
BUILD_OPTIONS variable) to any value enables using the system library.
The default behavior of using a bundled copy of libgit2 is unchanged.
---
CMakeLists.txt | 9 +++++++--
Makefile | 11 +++++++++++
src/CMakeLists.txt | 9 +++++++--
3 files changed, 25 insertions(+), 4 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a393d7c..75d6ca6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,9 +7,14 @@ set(BUILD_SHARED_LIBS OFF CACHE BOOL "shared" FORCE)
set(BUILD_CLAR OFF CACHE BOOL "clar" FORCE)
set(CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG} -DEGIT_DEBUG")
-add_subdirectory(libgit2)
+if(USE_SYSTEM_LIBGIT2)
+ find_package(PkgConfig REQUIRED)
+ pkg_check_modules(git2 REQUIRED IMPORTED_TARGET libgit2)
+else()
+ add_subdirectory(libgit2)
+ find_library(git2 libgit2.a)
+endif()
-find_library(git2 libgit2.a)
add_subdirectory(src)
enable_testing()
diff --git a/Makefile b/Makefile
index 8199532..6a6a4e1 100644
--- a/Makefile
+++ b/Makefile
@@ -13,6 +13,13 @@ ifeq ($(UNAME),MSYS)
BUILD_OPTIONS+= -G "MSYS Makefiles"
endif
+# If the variable USE_SYSTEM_LIBGIT2 is set to *any* value, use the
+# system provided libgit2 library.
+USE_SYSTEM_LIBGIT2? := \
+ $(if $(or $(USE_SYSTEM_LIBGIT2),\
+ $(findstring USE_SYSTEM_LIBGIT2,$(BUILD_OPTIONS))),\
+ true)
+
ifeq "$(TRAVIS)" "true"
## Makefile for Travis ###################################################
#
@@ -87,7 +94,11 @@ submodule-update:
@git submodule update
libgit2:
+ifeq ($(USE_SYSTEM_LIBGIT2?),)
@git submodule update --init
+else
+ @echo "Using the system provided libgit2 library"
+endif
CLEAN = $(ELCS) $(PKG)-autoloads.el build
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index cfb5777..0dbad8a 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -13,8 +13,13 @@ if(WIN32)
set_target_properties(egit2 PROPERTIES PREFIX lib)
endif(WIN32)
-target_link_libraries(egit2 git2)
-target_include_directories(egit2 SYSTEM PRIVATE "${libgit2_SOURCE_DIR}/include")
+if(USE_SYSTEM_LIBGIT2)
+ target_link_libraries(egit2 PRIVATE PkgConfig::git2)
+else()
+ target_link_libraries(egit2 git2)
+ target_include_directories(
+ egit2 SYSTEM PRIVATE "${libgit2_SOURCE_DIR}/include")
+endif()
if(CMAKE_COMPILER_IS_GNUCC)
target_compile_options(egit2 PRIVATE -Wall -Wextra)
--
2.26.2