gnu: WebKitGTK: Remove obsolete patch.

This patch was added in eb5f3ea100 and no longer
necessary since the update to 2.26.3 in f32ca55778.

* gnu/packages/patches/webkitgtk-icu-65.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/webkit.scm (webkitgtk)[source](patches): Remove.
This commit is contained in:
Marius Bakke 2020-02-03 20:18:52 +01:00
parent fe994a0c32
commit f0e810110b
No known key found for this signature in database
GPG key ID: A2A06DF2A33A54FA
3 changed files with 0 additions and 49 deletions

View file

@ -1480,7 +1480,6 @@ dist_patch_DATA = \
%D%/packages/patches/vte-CVE-2012-2738-pt1.patch \
%D%/packages/patches/vte-CVE-2012-2738-pt2.patch \
%D%/packages/patches/weasyprint-library-paths.patch \
%D%/packages/patches/webkitgtk-icu-65.patch \
%D%/packages/patches/websocketpp-fix-for-boost-1.70.patch \
%D%/packages/patches/wicd-bitrate-none-fix.patch \
%D%/packages/patches/wicd-get-selected-profile-fix.patch \

View file

@ -1,47 +0,0 @@
Fix build with ICU 65.
Taken from upstream:
https://bugs.webkit.org/show_bug.cgi?id=202600
https://trac.webkit.org/r250747
diff --git a/Source/WTF/wtf/URLHelpers.cpp b/Source/WTF/wtf/URLHelpers.cpp
index 18e7f13cd615..c584f1a0cb7e 100644
--- a/Source/WTF/wtf/URLHelpers.cpp
+++ b/Source/WTF/wtf/URLHelpers.cpp
@@ -301,7 +301,7 @@ static bool allCharactersInIDNScriptWhiteList(const UChar* buffer, int32_t lengt
Optional<UChar32> previousCodePoint;
while (i < length) {
UChar32 c;
- U16_NEXT(buffer, i, length, c)
+ U16_NEXT(buffer, i, length, c);
UErrorCode error = U_ZERO_ERROR;
UScriptCode script = uscript_getScript(c, &error);
if (error != U_ZERO_ERROR) {
diff --git a/Source/WebCore/dom/Document.cpp b/Source/WebCore/dom/Document.cpp
index 2443e24c9bc4..1fbb3a716006 100644
--- a/Source/WebCore/dom/Document.cpp
+++ b/Source/WebCore/dom/Document.cpp
@@ -4954,12 +4954,12 @@ static bool isValidNameNonASCII(const UChar* characters, unsigned length)
unsigned i = 0;
UChar32 c;
- U16_NEXT(characters, i, length, c)
+ U16_NEXT(characters, i, length, c);
if (!isValidNameStart(c))
return false;
while (i < length) {
- U16_NEXT(characters, i, length, c)
+ U16_NEXT(characters, i, length, c);
if (!isValidNamePart(c))
return false;
}
@@ -5019,7 +5019,7 @@ ExceptionOr<std::pair<AtomString, AtomString>> Document::parseQualifiedName(cons
for (unsigned i = 0; i < length; ) {
UChar32 c;
- U16_NEXT(qualifiedName, i, length, c)
+ U16_NEXT(qualifiedName, i, length, c);
if (c == ':') {
if (sawColon)
return Exception { InvalidCharacterError };

View file

@ -126,7 +126,6 @@ (define-public webkitgtk
(method url-fetch)
(uri (string-append "https://www.webkitgtk.org/releases/"
"webkitgtk-" version ".tar.xz"))
(patches (search-patches "webkitgtk-icu-65.patch"))
(sha256
(base32
"04g6y0sv04d20bw401myq3k828ikysjhx383ly81vh9wji9i3mdd"))))