gnu: s7: Compile with flint@3.

* gnu/packages/patches/s7-flint-3.patch: New file.
* gnu/local.mk (dist_patch_DATA): Register file.
* gnu/packages/lisp.scm (s7-bootstrap)[source]: Add patch.
[inputs]: Remove arb.

Change-Id: I06bac9d850977b8ee769e629f1b64411a8dc3247
This commit is contained in:
Andreas Enge 2024-01-25 12:29:30 +01:00
parent 619417ab23
commit f027a6c22c
No known key found for this signature in database
GPG key ID: F7D5C9BF765C61E3
3 changed files with 39 additions and 5 deletions

View file

@ -1,6 +1,6 @@
# GNU Guix --- Functional package management for GNU
# Copyright © 2012-2024 Ludovic Courtès <ludo@gnu.org>
# Copyright © 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020, 2022, 2023 Andreas Enge <andreas@enge.fr>
# Copyright © 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020, 2022, 2023, 2024 Andreas Enge <andreas@enge.fr>
# Copyright © 2016 Mathieu Lirzin <mthl@gnu.org>
# Copyright © 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020, 2021 Mark H Weaver <mhw@netris.org>
# Copyright © 2016 Chris Marusich <cmmarusich@gmail.com>
@ -2003,6 +2003,7 @@ dist_patch_DATA = \
%D%/packages/patches/rust-wl-clipboard-rs-newer-wl.patch \
%D%/packages/patches/rw-igraph-0.10.patch \
%D%/packages/patches/rxvt-unicode-fix-cursor-position.patch \
%D%/packages/patches/s7-flint-3.patch \
%D%/packages/patches/sbc-fix-build-non-x86.patch \
%D%/packages/patches/sbcl-aserve-add-HTML-5-elements.patch \
%D%/packages/patches/sbcl-aserve-fix-rfe12668.patch \

View file

@ -25,7 +25,8 @@
;;; Copyright © 2022 ( <paren@disroot.org>
;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2023 Yovan Naumovski <yovan@gorski.stream>
;;; Copyright © 2023 Andrew Kravchuk <awkravchuk@gmail.com.
;;; Copyright © 2023 Andrew Kravchuk <awkravchuk@gmail.com>
;;; Copyright © 2024 Andreas Enge <andreas@enge.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@ -1502,7 +1503,8 @@ (define-public s7-bootstrap
(file-name (git-file-name name version))
(sha256
(base32
"0fiw8lb7rswglixvn271la2q2hgwszrf2ckykhr6jjxdvmb9a7d0"))))
"0fiw8lb7rswglixvn271la2q2hgwszrf2ckykhr6jjxdvmb9a7d0"))
(patches (search-patches "s7-flint-3.patch"))))
(build-system gnu-build-system)
(arguments
(list #:tests? #f ;no tests in bootstrap
@ -1533,7 +1535,7 @@ (define-public s7-bootstrap
(invoke #$(cc-for-target) "libarb_s7.c"
"-I." "-O2" "-g"
"-shared" "-o" "libarb_s7.so"
"-larb" "-lflint" "-lmpc" "-fPIC")
"-lflint" "-lmpc" "-fPIC")
(display "[BUILD] libnotcurses_s7.so\n")
(invoke #$(cc-for-target) "notcurses_s7.c"
"-I." "-O2" "-g"
@ -1572,7 +1574,7 @@ (define-public s7-bootstrap
(install-file "s7.c" share)
(install-file "s7.h" inc)
(install-file "s7.html" doc)))))))
(inputs (list arb flint mpc notcurses))
(inputs (list flint mpc notcurses))
(home-page "https://ccrma.stanford.edu/software/snd/snd/s7.html")
(synopsis "Scheme interpreter intended as an extension language")
(description

View file

@ -0,0 +1,31 @@
From bd54bd42c5933e4c571dcfd6a8afac8e52cf7366 Mon Sep 17 00:00:00 2001
From: Andreas Enge <andreas@enge.fr>
Date: Thu, 25 Jan 2024 12:13:18 +0100
Subject: [PATCH] Adapt libarb_s7.c to FLINT 3.
---
libarb_s7.c | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/libarb_s7.c b/libarb_s7.c
index 7413ccc..d9e0084 100644
--- a/libarb_s7.c
+++ b/libarb_s7.c
@@ -6,10 +6,10 @@
#include <mpfr.h>
#include <mpc.h>
-#include <arb.h>
-#include <acb.h>
-#include <acb_hypgeom.h>
-#include <acb_elliptic.h>
+#include <flint/arb.h>
+#include <flint/acb.h>
+#include <flint/acb_hypgeom.h>
+#include <flint/acb_elliptic.h>
#define WITH_GMP 1
#include "s7.h"
--
2.41.0