Revert "gnu: guile-static-stripped: Update to 2.2."
As discussed on IRC, keeping bootstrap Guile on 2.0 simplifies adding new
architectures and removes the need for parameterizing
gnu/packages/bootstrap.scm.
This reverts commit 2acfe022a7
.
* gnu/packages/make-bootstrap.scm (%guile-static): Revert to guile-2.0. Retain
build recipe.
* gnu/packages/patches/guile-relocatable.patch: Update for Guile 2.0.14.
This commit is contained in:
parent
ee1cf1dd80
commit
eef44fea17
4 changed files with 40 additions and 109 deletions
|
@ -1000,7 +1000,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/grub-verifiers-Blocklist-fallout-cleanup.patch \
|
||||
%D%/packages/patches/gspell-dash-test.patch \
|
||||
%D%/packages/patches/guile-1.8-cpp-4.5.patch \
|
||||
%D%/packages/patches/guile-2.2-default-utf8.patch \
|
||||
%D%/packages/patches/guile-2.2-skip-oom-test.patch \
|
||||
%D%/packages/patches/guile-3.0-crash.patch \
|
||||
%D%/packages/patches/guile-default-utf8.patch \
|
||||
|
|
|
@ -679,18 +679,18 @@ (define %guile-static
|
|||
;; .scm and .go files relative to its installation directory, rather
|
||||
;; than in hard-coded configure-time paths.
|
||||
(let* ((patches (cons* (search-patch "guile-relocatable.patch")
|
||||
(search-patch "guile-2.2-default-utf8.patch")
|
||||
(search-patch "guile-default-utf8.patch")
|
||||
(search-patch "guile-linux-syscalls.patch")
|
||||
(origin-patches (package-source guile-2.2))))
|
||||
(source (origin (inherit (package-source guile-2.2))
|
||||
(origin-patches (package-source guile-2.0))))
|
||||
(source (origin (inherit (package-source guile-2.0))
|
||||
(patches patches)))
|
||||
(guile (package (inherit guile-2.2)
|
||||
(name (string-append (package-name guile-2.2) "-static"))
|
||||
(guile (package (inherit guile-2.0)
|
||||
(name (string-append (package-name guile-2.0) "-static"))
|
||||
(source source)
|
||||
(synopsis "Statically-linked and relocatable Guile")
|
||||
|
||||
;; Remove the 'debug' output (see above for the reason.)
|
||||
(outputs (delete "debug" (package-outputs guile-2.2)))
|
||||
(outputs (delete "debug" (package-outputs guile-2.0)))
|
||||
|
||||
(inputs
|
||||
`(("libunistring:static" ,libunistring "static")
|
||||
|
@ -699,9 +699,9 @@ (define %guile-static
|
|||
(propagated-inputs
|
||||
`(("bdw-gc" ,libgc)
|
||||
,@(alist-delete "bdw-gc"
|
||||
(package-propagated-inputs guile-2.2))))
|
||||
(package-propagated-inputs guile-2.0))))
|
||||
(arguments
|
||||
(substitute-keyword-arguments (package-arguments guile-2.2)
|
||||
(substitute-keyword-arguments (package-arguments guile-2.0)
|
||||
((#:configure-flags flags '())
|
||||
;; When `configure' checks for ltdl availability, it
|
||||
;; doesn't try to link using libtool, and thus fails
|
||||
|
@ -724,7 +724,7 @@ (define %guile-static
|
|||
(("^guile_LDFLAGS =")
|
||||
"guile_LDFLAGS = -all-static")
|
||||
|
||||
;; Add `-ldl' *after* libguile-2.2.la.
|
||||
;; Add `-ldl' *after* libguile-2.0.la.
|
||||
(("^guile_LDADD =(.*)$" _ ldadd)
|
||||
(string-append "guile_LDADD = "
|
||||
(string-trim-right ldadd)
|
||||
|
@ -756,13 +756,13 @@ (define %guile-static-stripped
|
|||
(out (assoc-ref %outputs "out"))
|
||||
(guile1 (string-append in "/bin/guile"))
|
||||
(guile2 (string-append out "/bin/guile")))
|
||||
(mkdir-p (string-append out "/share/guile/2.2"))
|
||||
(copy-recursively (string-append in "/share/guile/2.2")
|
||||
(string-append out "/share/guile/2.2"))
|
||||
(mkdir-p (string-append out "/share/guile/2.0"))
|
||||
(copy-recursively (string-append in "/share/guile/2.0")
|
||||
(string-append out "/share/guile/2.0"))
|
||||
|
||||
(mkdir-p (string-append out "/lib/guile/2.2/ccache"))
|
||||
(copy-recursively (string-append in "/lib/guile/2.2/ccache")
|
||||
(string-append out "/lib/guile/2.2/ccache"))
|
||||
(mkdir-p (string-append out "/lib/guile/2.0/ccache"))
|
||||
(copy-recursively (string-append in "/lib/guile/2.0/ccache")
|
||||
(string-append out "/lib/guile/2.0/ccache"))
|
||||
|
||||
(mkdir (string-append out "/bin"))
|
||||
(copy-file guile1 guile2)
|
||||
|
|
|
@ -1,82 +0,0 @@
|
|||
This hack makes Guile default to UTF-8. This avoids calls to
|
||||
`iconv_open'; `iconv_open' tries to open shared objects that aren't
|
||||
available during bootstrap, so using UTF-8 avoids that (and UTF-8 has
|
||||
built-in conversions in glibc, too.)
|
||||
|
||||
diff --git a/libguile/bytevectors.c b/libguile/bytevectors.c
|
||||
index 0ac5ea6a6..f73301e2f 100644
|
||||
--- a/libguile/bytevectors.c
|
||||
+++ b/libguile/bytevectors.c
|
||||
@@ -1931,7 +1931,7 @@ utf_encoding_name (char *name, size_t utf_width, SCM endianness)
|
||||
if (scm_i_is_narrow_string (str)) \
|
||||
{ \
|
||||
err = mem_iconveh (scm_i_string_chars (str), c_strlen, \
|
||||
- "ISO-8859-1", c_utf_name, \
|
||||
+ "UTF-8", c_utf_name, \
|
||||
iconveh_question_mark, NULL, \
|
||||
&c_utf, &c_utf_len); \
|
||||
if (SCM_UNLIKELY (err)) \
|
||||
diff --git a/libguile/ports.c b/libguile/ports.c
|
||||
index 45e62f4e4..42012f3aa 100644
|
||||
--- a/libguile/ports.c
|
||||
+++ b/libguile/ports.c
|
||||
@@ -974,7 +974,9 @@ canonicalize_encoding (const char *enc)
|
||||
char *ret;
|
||||
int i;
|
||||
|
||||
- if (!enc || encoding_matches (enc, sym_ISO_8859_1))
|
||||
+ if (enc == NULL)
|
||||
+ return sym_UTF_8;
|
||||
+ if (encoding_matches (enc, sym_ISO_8859_1))
|
||||
return sym_ISO_8859_1;
|
||||
if (encoding_matches (enc, sym_UTF_8))
|
||||
return sym_UTF_8;
|
||||
@@ -4198,7 +4200,7 @@ scm_init_ports (void)
|
||||
scm_c_define ("%default-port-conversion-strategy",
|
||||
scm_make_fluid_with_default (sym_substitute));
|
||||
/* Use the locale as the default port encoding. */
|
||||
- scm_i_set_default_port_encoding (locale_charset ());
|
||||
+ scm_i_set_default_port_encoding ("UTF-8");
|
||||
|
||||
scm_c_register_extension ("libguile-" SCM_EFFECTIVE_VERSION,
|
||||
"scm_init_ice_9_ports",
|
||||
diff --git a/libguile/strings.c b/libguile/strings.c
|
||||
index 056b4c99f..63a6c050d 100644
|
||||
--- a/libguile/strings.c
|
||||
+++ b/libguile/strings.c
|
||||
@@ -1579,7 +1579,7 @@ scm_i_default_string_failed_conversion_handler (void)
|
||||
SCM
|
||||
scm_from_locale_stringn (const char *str, size_t len)
|
||||
{
|
||||
- return scm_from_stringn (str, len, locale_charset (),
|
||||
+ return scm_from_stringn (str, len, "UTF-8",
|
||||
scm_i_default_string_failed_conversion_handler ());
|
||||
}
|
||||
|
||||
@@ -1907,7 +1907,7 @@ char *
|
||||
scm_to_locale_stringn (SCM str, size_t *lenp)
|
||||
{
|
||||
return scm_to_stringn (str, lenp,
|
||||
- locale_charset (),
|
||||
+ "UTF-8",
|
||||
scm_i_default_string_failed_conversion_handler ());
|
||||
}
|
||||
|
||||
@@ -2195,7 +2195,7 @@ scm_to_stringn (SCM str, size_t *lenp, const char *encoding,
|
||||
scm_wrong_type_arg_msg (NULL, 0, str, "string");
|
||||
|
||||
if (encoding == NULL)
|
||||
- encoding = "ISO-8859-1";
|
||||
+ encoding = "UTF-8";
|
||||
|
||||
if (c_strcasecmp (encoding, "UTF-8") == 0)
|
||||
/* This is the most common case--e.g., when calling libc bindings
|
||||
@@ -2247,7 +2247,7 @@ scm_to_stringn (SCM str, size_t *lenp, const char *encoding,
|
||||
if (scm_i_is_narrow_string (str))
|
||||
{
|
||||
ret = mem_iconveh (scm_i_string_chars (str), ilen,
|
||||
- "ISO-8859-1", encoding,
|
||||
+ "UTF-8", encoding,
|
||||
(enum iconv_ilseq_handler) handler, NULL,
|
||||
&buf, &len);
|
||||
|
|
@ -1,6 +1,17 @@
|
|||
This patch changes Guile to use a default search path relative to the
|
||||
location of the `guile' binary, allowing it to be relocated.
|
||||
From 501ad55982a8f92a7a95c76c75944d644870181d Mon Sep 17 00:00:00 2001
|
||||
From: Ludovic Courtès <ludo@gnu.org>
|
||||
Date: Thu, 12 Mar 2020 15:16:04 +0100
|
||||
Subject: [PATCH] load: Make Guile run-time relocatable using /proc/self/exe.
|
||||
|
||||
Import from
|
||||
|
||||
http://git.savannah.gnu.org/cgit/guix.git/commit/?id=920f2c42ce3345dc1355a41377ebf01a33fdae51
|
||||
---
|
||||
libguile/load.c | 35 +++++++++++++++++++++++++++++------
|
||||
1 file changed, 29 insertions(+), 6 deletions(-)
|
||||
|
||||
diff --git a/libguile/load.c b/libguile/load.c
|
||||
index c2ee5093a..128cdf95a 100644
|
||||
--- a/libguile/load.c
|
||||
+++ b/libguile/load.c
|
||||
@@ -26,6 +26,7 @@
|
||||
|
@ -11,7 +22,7 @@ location of the `guile' binary, allowing it to be relocated.
|
|||
|
||||
#include "libguile/_scm.h"
|
||||
#include "libguile/alist.h"
|
||||
@@ -326,6 +327,32 @@ scm_init_load_path ()
|
||||
@@ -325,6 +326,32 @@ scm_init_load_path ()
|
||||
SCM cpath = SCM_EOL;
|
||||
|
||||
#ifdef SCM_LIBRARY_DIR
|
||||
|
@ -44,25 +55,28 @@ location of the `guile' binary, allowing it to be relocated.
|
|||
env = scm_i_mirror_backslashes (getenv ("GUILE_SYSTEM_PATH"));
|
||||
if (env && strcmp (env, "") == 0)
|
||||
/* special-case interpret system-path=="" as meaning no system path instead
|
||||
@@ -334,10 +361,7 @@ scm_init_load_path ()
|
||||
@@ -333,10 +360,7 @@ scm_init_load_path ()
|
||||
else if (env)
|
||||
path = scm_parse_path (scm_from_locale_string (env), path);
|
||||
else
|
||||
- path = scm_list_4 (scm_from_utf8_string (SCM_LIBRARY_DIR),
|
||||
- scm_from_utf8_string (SCM_SITE_DIR),
|
||||
- scm_from_utf8_string (SCM_GLOBAL_SITE_DIR),
|
||||
- scm_from_utf8_string (SCM_PKGDATA_DIR));
|
||||
- path = scm_list_4 (scm_from_locale_string (SCM_LIBRARY_DIR),
|
||||
- scm_from_locale_string (SCM_SITE_DIR),
|
||||
- scm_from_locale_string (SCM_GLOBAL_SITE_DIR),
|
||||
- scm_from_locale_string (SCM_PKGDATA_DIR));
|
||||
+ path = scm_list_1 (scm_from_locale_string (module_dir));
|
||||
|
||||
env = scm_i_mirror_backslashes (getenv ("GUILE_SYSTEM_COMPILED_PATH"));
|
||||
if (env && strcmp (env, "") == 0)
|
||||
@@ -347,8 +371,7 @@ scm_init_load_path ()
|
||||
@@ -346,8 +370,7 @@ scm_init_load_path ()
|
||||
cpath = scm_parse_path (scm_from_locale_string (env), cpath);
|
||||
else
|
||||
{
|
||||
- cpath = scm_list_2 (scm_from_utf8_string (SCM_CCACHE_DIR),
|
||||
- scm_from_utf8_string (SCM_SITE_CCACHE_DIR));
|
||||
- cpath = scm_list_2 (scm_from_locale_string (SCM_CCACHE_DIR),
|
||||
- scm_from_locale_string (SCM_SITE_CCACHE_DIR));
|
||||
+ cpath = scm_list_1 (scm_from_locale_string (ccache_dir));
|
||||
}
|
||||
|
||||
#endif /* SCM_LIBRARY_DIR */
|
||||
--
|
||||
2.24.0
|
||||
|
||||
|
|
Loading…
Reference in a new issue