gnu: Rename u-boot-sifive-fu540 to sifive-unleashed.

* gnu/packages/bootloaders.scm (u-boot-sifive-fu540): Rename to ...
(u-boot-sifive-unleashed): ... this.  Change board name from sifive_fu540 to
sifive_unleashed.
* gnu/packages/patches/u-boot-riscv64-fix-extlinux.patch: Rename sifive_fu540
to sifive_unleashed.
This commit is contained in:
Pierre Langlois 2021-08-02 15:13:11 +01:00
parent 781123518e
commit e914fc5913
No known key found for this signature in database
GPG key ID: A8FC9E447F4F7D54
2 changed files with 4 additions and 4 deletions

View file

@ -869,8 +869,8 @@ (define-public u-boot-qemu-riscv64-smode
(patches
(search-patches "u-boot-riscv64-fix-extlinux.patch")))))))
(define-public u-boot-sifive-fu540
(make-u-boot-package "sifive_fu540" "riscv64-linux-gnu"))
(define-public u-boot-sifive-unleashed
(make-u-boot-package "sifive_unleashed" "riscv64-linux-gnu"))
(define-public u-boot-sifive-unmatched
(make-u-boot-package "sifive_unmatched" "riscv64-linux-gnu"))

View file

@ -30,8 +30,8 @@ Index: u-boot/configs/qemu-riscv64_smode_defconfig
+CONFIG_PREBOOT="setenv fdt_addr ${fdtcontroladdr}; fdt addr ${fdtcontroladdr};"
Index: u-boot/configs/sifive_fu540_defconfig
===================================================================
--- u-boot.orig/configs/sifive_fu540_defconfig
+++ u-boot/configs/sifive_fu540_defconfig
--- u-boot.orig/configs/sifive_unleashed_defconfig
+++ u-boot/configs/sifive_unleashed_defconfig
@@ -27,3 +27,5 @@ CONFIG_SPL_DM_SEQ_ALIAS=y
CONFIG_SPL_CLK=y
CONFIG_DM_MTD=y