gnu: boost: Remove GCC5 workaround.

* gnu/packages/patches/boost-fix-icu-build.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/boost.scm (boost)[source](patches): Remove.
[arguments]: Do not pass "cxxflags".
This commit is contained in:
Marius Bakke 2019-07-02 21:17:53 +02:00
parent fefd1a7bd4
commit e7a42c4abb
No known key found for this signature in database
GPG key ID: A2A06DF2A33A54FA
3 changed files with 1 additions and 57 deletions

View file

@ -698,7 +698,6 @@ dist_patch_DATA = \
%D%/packages/patches/binutils-loongson-workaround.patch \
%D%/packages/patches/blender-2.79-newer-ffmpeg.patch \
%D%/packages/patches/blender-2.79-python-3.7-fix.patch \
%D%/packages/patches/boost-fix-icu-build.patch \
%D%/packages/patches/byobu-writable-status.patch \
%D%/packages/patches/calibre-no-updates-dialog.patch \
%D%/packages/patches/calibre-remove-test-bs4.patch \

View file

@ -56,8 +56,7 @@ (define-public boost
version-with-underscores ".tar.bz2"))))
(sha256
(base32
"0y47nc7w0arwgj4x1phadxbvl7wyfcgknbz5kv8lzpl98wsyh2j3"))
(patches (search-patches "boost-fix-icu-build.patch"))))
"0y47nc7w0arwgj4x1phadxbvl7wyfcgknbz5kv8lzpl98wsyh2j3"))))
(build-system gnu-build-system)
(inputs `(("icu4c" ,icu4c)
("zlib" ,zlib)))
@ -69,7 +68,6 @@ (define-public boost
`(#:tests? #f
#:make-flags
(list "threading=multi" "link=shared"
"cxxflags=-std=c++14"
;; Set the RUNPATH to $libdir so that the libs find each other.
(string-append "linkflags=-Wl,-rpath="

View file

@ -1,53 +0,0 @@
Pass -std=c++11 when compiling files that include the ICU headers. Without
this flag, compilation fails and causes Boost's build system to remove ICU
support. Note that $(pkg-config --variable=CXXFLAGS icu-uc) includes
"-std=c++11", but Boost's build system does not use 'pkg-config'.
--- boost_1_66_0/libs/locale/build/Jamfile.v2.orig 2017-12-13 18:56:44.000000000 -0500
+++ boost_1_66_0/libs/locale/build/Jamfile.v2 2018-04-08 15:18:58.673025760 -0400
@@ -65,8 +65,8 @@
if $(ICU_LINK)
{
- ICU_OPTS = <include>$(ICU_PATH)/include <linkflags>$(ICU_LINK) <dll-path>$(ICU_PATH)/bin <runtime-link>shared ;
- ICU64_OPTS = <include>$(ICU_PATH)/include <linkflags>$(ICU_LINK) <dll-path>$(ICU_PATH)/bin64 <runtime-link>shared ;
+ ICU_OPTS = <include>$(ICU_PATH)/include <cxxflags>-std=c++11 <linkflags>$(ICU_LINK) <dll-path>$(ICU_PATH)/bin <runtime-link>shared ;
+ ICU64_OPTS = <include>$(ICU_PATH)/include <cxxflags>-std=c++11 <linkflags>$(ICU_LINK) <dll-path>$(ICU_PATH)/bin64 <runtime-link>shared ;
}
else
{
@@ -121,6 +121,7 @@
explicit icuuc icudt icuin ;
ICU_OPTS = <include>$(ICU_PATH)/include
+ <cxxflags>-std=c++11
<library>icuuc/<link>shared/<runtime-link>shared
<library>icudt/<link>shared/<runtime-link>shared
<library>icuin/<link>shared/<runtime-link>shared
@@ -180,6 +181,7 @@
explicit icuuc_64 icudt_64 icuin_64 ;
ICU64_OPTS = <include>$(ICU_PATH)/include
+ <cxxflags>-std=c++11
<library>icuuc_64/<link>shared/<runtime-link>shared
<library>icudt_64/<link>shared/<runtime-link>shared
<library>icuin_64/<link>shared/<runtime-link>shared
--- boost_1_66_0/libs/regex/build/Jamfile.v2.orig 2017-12-13 18:56:48.000000000 -0500
+++ boost_1_66_0/libs/regex/build/Jamfile.v2 2018-04-08 15:20:40.865532505 -0400
@@ -44,7 +44,7 @@
if $(ICU_LINK)
{
- ICU_OPTS = <include>$(ICU_PATH)/include <linkflags>$(ICU_LINK) <dll-path>$(ICU_PATH)/bin <define>BOOST_HAS_ICU=1 <runtime-link>shared ;
+ ICU_OPTS = <include>$(ICU_PATH)/include <cxxflags>-std=c++11 <linkflags>$(ICU_LINK) <dll-path>$(ICU_PATH)/bin <define>BOOST_HAS_ICU=1 <runtime-link>shared ;
}
else
{
@@ -78,6 +78,7 @@
ICU_OPTS =
<include>$(ICU_PATH)/include
+ <cxxflags>-std=c++11
<runtime-link>shared:<library>icuuc/<link>shared
<runtime-link>shared:<library>icudt/<link>shared
<runtime-link>shared:<library>icuin/<link>shared