gnu: evilwm: Update to 1.3.1.
* gnu/packages/wm.scm (evilwm): Update to 1.3.1. [source]: Remove patch. * gnu/packages/patches/evilwm-lost-focus-bug.patch: Remove. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.
This commit is contained in:
parent
207a1625e9
commit
e725b24d11
3 changed files with 4 additions and 24 deletions
|
@ -1040,7 +1040,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/erlang-man-path.patch \
|
||||
%D%/packages/patches/esmtp-add-lesmtp.patch \
|
||||
%D%/packages/patches/eudev-rules-directory.patch \
|
||||
%D%/packages/patches/evilwm-lost-focus-bug.patch \
|
||||
%D%/packages/patches/exercism-disable-self-update.patch \
|
||||
%D%/packages/patches/extempore-unbundle-external-dependencies.patch \
|
||||
%D%/packages/patches/extundelete-e2fsprogs-1.44.patch \
|
||||
|
|
|
@ -1,18 +0,0 @@
|
|||
evilwm may sometimes lose focus after closing a window. This means that
|
||||
evilwm stops responding to keyboard shortcuts, and if no other window is open
|
||||
which the mouse can be moved over to regain focus evilwm becomes unusable and
|
||||
has to be restarted.
|
||||
|
||||
Patch derived from discussion at
|
||||
https://wiki.archlinux.org/index.php/Evilwm#Lost_focus_bug_fix
|
||||
|
||||
--- evilwm-1.1.1/client.c
|
||||
+++ evilwm-1.1.1/client.c
|
||||
@@ -172,6 +172,7 @@
|
||||
* _NET_WM_STATE) */
|
||||
if (c->remove) {
|
||||
LOG_DEBUG("setting WithdrawnState\n");
|
||||
+ XSetInputFocus(dpy, PointerRoot, RevertToPointerRoot, CurrentTime);
|
||||
set_wm_state(c, WithdrawnState);
|
||||
ewmh_withdraw_client(c);
|
||||
} else {
|
|
@ -1,7 +1,7 @@
|
|||
;;; GNU Guix --- Functional package management for GNU
|
||||
;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
|
||||
;;; Copyright © 2015 Siniša Biđin <sinisa@bidin.eu>
|
||||
;;; Copyright © 2015, 2016 Eric Bavier <bavier@member.fsf.org>
|
||||
;;; Copyright © 2015, 2016, 2022 Eric Bavier <bavier@posteo.net>
|
||||
;;; Copyright © 2015 xd1le <elisp.vim@gmail.com>
|
||||
;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
|
||||
;;; Copyright © 2016 Danny Milosavljevic <dannym@scratchpost.org>
|
||||
|
@ -937,16 +937,15 @@ (define-public ghc-xmonad-contrib
|
|||
(define-public evilwm
|
||||
(package
|
||||
(name "evilwm")
|
||||
(version "1.1.1")
|
||||
(version "1.3.1")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "http://www.6809.org.uk/evilwm/evilwm-"
|
||||
(uri (string-append "http://www.6809.org.uk/evilwm/dl/evilwm-"
|
||||
version ".tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"0ak0yajzk3v4dg5wmaghv6acf7v02a4iw8qxmq5yw5ard8lrqn3r"))
|
||||
(patches (search-patches "evilwm-lost-focus-bug.patch"))))
|
||||
"1jry36qkg2l02v37zvzszxvxm2d8c62z25gks5gdqqjl9ifbpv1j"))))
|
||||
(build-system gnu-build-system)
|
||||
(inputs
|
||||
(list libx11 libxext libxrandr))
|
||||
|
|
Loading…
Reference in a new issue