gnu: diffoscope: Use newer llvm.

* gnu/packages/diffoscope.scm (diffoscope)[source]: Remove patch.
[native-inputs]: Replace llvm-9 with llvm.
* gnu/packages/patches/diffoscope-fix-llvm-test.patch: Remove file.
* gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
Efraim Flashner 2023-01-25 09:41:43 +02:00
parent 718223c58c
commit e71dc64e23
No known key found for this signature in database
GPG key ID: 41AAE7DCCA3D8351
3 changed files with 3 additions and 35 deletions

View file

@ -1038,7 +1038,6 @@ dist_patch_DATA = \
%D%/packages/patches/desmume-gcc6-fixes.patch \
%D%/packages/patches/desmume-gcc7-fixes.patch \
%D%/packages/patches/dfu-programmer-fix-libusb.patch \
%D%/packages/patches/diffoscope-fix-llvm-test.patch \
%D%/packages/patches/diffutils-fix-signal-processing.patch \
%D%/packages/patches/dkimproxy-add-ipv6-support.patch \
%D%/packages/patches/docbook-xsl-nonrecursive-string-subst.patch \

View file

@ -5,7 +5,7 @@
;;; Copyright © 2018 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2018, 2019 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2019 Vagrant Cascadian <vagrant@reproducible-builds.org>
;;; Copyright © 2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2022, 2023 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@ -84,9 +84,7 @@ (define-public diffoscope
(commit version)))
(file-name (git-file-name name version))
(sha256
(base32 "1m6fc7k8cd7ahra05vqccw1fdbjj6d20vr3q8v67ynnyih5nmbnb"))
(patches
(search-patches "diffoscope-fix-llvm-test.patch"))))
(base32 "1m6fc7k8cd7ahra05vqccw1fdbjj6d20vr3q8v67ynnyih5nmbnb"))))
(build-system python-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
@ -193,7 +191,7 @@ (define-public diffoscope
hdf5
imagemagick
libarchive
llvm-9
llvm
lz4
lzip
ocaml

View file

@ -1,29 +0,0 @@
From b7eeac09eb068083bdee1a3aa062d1e52a2fa61a Mon Sep 17 00:00:00 2001
From: Tobias Geerinckx-Rice <me@tobias.gr>
Date: Mon, 4 Oct 2021 21:03:43 +0200
Subject: [PATCH] gnu: diffoscope: Fix test_item3_deflate_llvm_bitcode.
Taken verbatim from Nixpkgs[0]. Later extended for diffoscope >= 224.
[0]: https://github.com/NixOS/nixpkgs/blob/589e03f109092a3ba97781fd0533110bf78a3f97/pkgs/tools/misc/diffoscope/fix-tests.patch
---
tests/comparators/test_rlib.py | 3 ---
1 file changed, 3 deletions(-)
diff --git a/tests/comparators/test_rlib.py b/tests/comparators/test_rlib.py
index 8a20114d..64cea17f 100644
--- a/tests/comparators/test_rlib.py
+++ b/tests/comparators/test_rlib.py
@@ -80,12 +80,6 @@ def rlib_dis_expected_diff():
if actual_ver >= "7.0":
diff_file = "rlib_llvm_dis_expected_diff_7"
- if actual_ver >= "10.0":
- diff_file = "rlib_llvm_dis_expected_diff_10"
-
- if actual_ver >= "15.0":
- diff_file = "rlib_llvm_dis_expected_diff_15"
-
return get_data(diff_file)