gnu: Add go-github-com-pkg-xattr.

* gnu/packages/golang.scm (go-github-com-pkg-xattr): New variable.

Signed-off-by: Leo Famulari <leo@famulari.name>
This commit is contained in:
Felix Lechner 2023-03-05 12:54:53 -08:00 committed by Leo Famulari
parent 48f8f9048d
commit e64286d6e0
No known key found for this signature in database
GPG key ID: 2646FA30BACA7F08

View file

@ -1406,6 +1406,36 @@ (define-public go-github-com-kortschak-utter
aid data snapshotting.")
(license license:isc)))
(define-public go-github-com-pkg-xattr
(package
(name "go-github-com-pkg-xattr")
(version "0.4.9")
(source (origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/pkg/xattr")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32
"0qg4zh0d8m4adaiicsd0cpw0w6g8sk01f4jz7jyxgirh1wfcsqyz"))))
(build-system go-build-system)
(arguments
'(#:import-path "github.com/pkg/xattr"))
(native-inputs (list go-golang-org-x-sys))
(home-page "https://github.com/pkg/xattr")
(synopsis "Support for extended file system attributes")
(description
"Package xattr provides support for extended attributes on Linux, Darwin and
FreeBSD. Extended attributes are name:value pairs permanently associated with
files or directories. They are similar to the environment strings associated with
a process. An attribute may be defined or undefined. If defined, its value may
be empty or non-empty. You can find more details here:
@@url{https://en.wikipedia.org/wiki/Extended_file_attributes,
https://en.wikipedia.org/wiki/Extended_file_attributes}
.")
(license license:bsd-2)))
(define-public go-github-com-shadowsocks-go-shadowsocks2
(package
(name "go-github-com-shadowsocks-go-shadowsocks2")