gnu: libgit2: Update to 1.3.0.

* gnu/packages/patches/libgit2-mtime-0.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): De-register it.
* gnu/packages/version-control.scm (libgit2): Update to 1.3.0.
[source]: Remove patch and simplify snippet.
[phases]: Remove trailing #t.
This commit is contained in:
Maxim Cournoyer 2021-11-22 11:49:00 -05:00
parent 12f68319e8
commit e0e2316420
No known key found for this signature in database
GPG key ID: 1260E46482E63562
3 changed files with 12 additions and 27 deletions

View file

@ -1347,7 +1347,6 @@ dist_patch_DATA = \
%D%/packages/patches/libcyaml-libyaml-compat.patch \
%D%/packages/patches/libexpected-nofetch.patch \
%D%/packages/patches/libgeotiff-adapt-test-script-for-proj-6.2.patch \
%D%/packages/patches/libgit2-mtime-0.patch \
%D%/packages/patches/libgnome-encoding.patch \
%D%/packages/patches/libgnomeui-utf8.patch \
%D%/packages/patches/libgrss-CVE-2016-2001.patch \

View file

@ -1,14 +0,0 @@
The Clar test framework has a bug whereby it skips the parsing phase
on files with mtime=0.
Reported upstream at <https://github.com/vmg/clar/pull/78>.
diff --git a/tests/generate.py b/tests/generate.py
index b639c8f..111ca41 100644
--- a/tests/generate.py
+++ b/tests/generate.py
@@ -63,3 +63,3 @@ class Module(object):
- self.mtime = 0
+ self.mtime = None # Guix sets all file mtimes to '0'
self.enabled = True

View file

@ -786,19 +786,20 @@ (define-public git-cal
(define-public libgit2
(package
(name "libgit2")
(version "1.1.0")
(version "1.3.0")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/libgit2/libgit2/"
"releases/download/v" version
"/libgit2-" version ".tar.gz"))
;; Since v1.1.1, release artifacts are no longer offered (see:
;; https://github.com/libgit2/libgit2/discussions/5932#discussioncomment-1682729).
(method git-fetch)
(uri (git-reference
(url "https://github.com/libgit2/libgit2")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32
"1fjdglkh04qv3b4alg621pxa689i0wlf8m7nf2755zawjr2zhwxd"))
(patches (search-patches "libgit2-mtime-0.patch"))
(snippet '(begin
(delete-file-recursively "deps") #t))
(modules '((guix build utils)))))
"0vgpb2175a5dhqiy1iwywwppahgqhi340i8bsvafjpvkw284vazd"))
(modules '((guix build utils)))
(snippet '(delete-file-recursively "deps"))))
(build-system cmake-build-system)
(outputs '("out" "debug"))
(arguments
@ -820,8 +821,7 @@ (define-public libgit2
(("#!/bin/sh") (string-append "#!" (which "sh"))))
(substitute* "tests/clar/fs.h"
(("/bin/cp") (which "cp"))
(("/bin/rm") (which "rm")))
#t))
(("/bin/rm") (which "rm")))))
;; Run checks more verbosely, unless we are cross-compiling.
(replace 'check
(lambda* (#:key (tests? #t) #:allow-other-keys)