gnu: tor: Update to 0.4.8.5.

* gnu/packages/tor.scm (tor): Update to 0.4.8.5.
* gnu/packages/tor.scm (tor)[arguments]<#:configure-flags>:
Add "--enable-gpl".
* gnu/packages/patches/tor-remove-defensive-assert.patch: New file.
* gnu/local.mk (dist_patch_DATA): Register it.
* gnu/packages/tor.scm (tor)[source]: Add patch to remove defensive
  assert.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
This commit is contained in:
fanquake 2023-08-24 09:47:33 +01:00 committed by Ludovic Courtès
parent 08e8c3483f
commit de64e412f3
No known key found for this signature in database
GPG key ID: 090B11993D9AEBB5
3 changed files with 34 additions and 3 deletions

View file

@ -2018,6 +2018,7 @@ dist_patch_DATA = \
%D%/packages/patches/tofi-32bit-compat.patch \ %D%/packages/patches/tofi-32bit-compat.patch \
%D%/packages/patches/tootle-glib-object-naming.patch \ %D%/packages/patches/tootle-glib-object-naming.patch \
%D%/packages/patches/tootle-reason-phrase.patch \ %D%/packages/patches/tootle-reason-phrase.patch \
%D%/packages/patches/tor-remove-defensive-assert.patch \
%D%/packages/patches/transcode-ffmpeg.patch \ %D%/packages/patches/transcode-ffmpeg.patch \
%D%/packages/patches/transfig-gcc10-fno-common.patch \ %D%/packages/patches/transfig-gcc10-fno-common.patch \
%D%/packages/patches/trytond-add-egg-modules-to-path.patch \ %D%/packages/patches/trytond-add-egg-modules-to-path.patch \

View file

@ -0,0 +1,28 @@
This patch removes a call to `tor_assert_nonfatal_unreached()` in
`relay_key_is_unavailable_()` that is only called when Tor is compiled
without relay support.
Unfortunately, the non-fatal assertion causes a BUG log
message to appear for clients when they start up without relay support
for each CPU worker we spawn. This makes it spotting issues during
bootstrap harder particularly for our iOS developers.
Since the call sites to `get_master_identity_key()` handles `NULL`
values already, we do not think this will be an issue later on.
Reported by Benjamin Erhart (@tla) from Guardian Project.
Fixes tpo/core/tor#40848.
diff --git a/src/feature/relay/routerkeys.h b/src/feature/relay/routerkeys.h
index 7b6d80773c..b97615a9c9 100644
--- a/src/feature/relay/routerkeys.h
+++ b/src/feature/relay/routerkeys.h
@@ -53,7 +53,6 @@ void routerkeys_free_all(void);
static inline void *
relay_key_is_unavailable_(void)
{
- tor_assert_nonfatal_unreached();
return NULL;
}
#define relay_key_is_unavailable(type) \

View file

@ -63,18 +63,20 @@ (define-module (gnu packages tor)
(define-public tor (define-public tor
(package (package
(name "tor") (name "tor")
(version "0.4.7.14") (version "0.4.8.5")
(source (origin (source (origin
(method url-fetch) (method url-fetch)
(uri (string-append "https://dist.torproject.org/tor-" (uri (string-append "https://dist.torproject.org/tor-"
version ".tar.gz")) version ".tar.gz"))
(sha256 (sha256
(base32 (base32
"1y2xwrji1rvk6h0k15705yra5s74h72h2g84x02zr0338vv6gb55")))) "06g1awb4piqvgxa97pyswxgjzkpj8rx3iy2jbiaygvi99b8wymv9"))
(patches (search-patches "tor-remove-defensive-assert.patch"))))
(build-system gnu-build-system) (build-system gnu-build-system)
(arguments (arguments
(list #:configure-flags (list #:configure-flags
#~(list "--enable-lzma" #~(list "--enable-gpl"
"--enable-lzma"
"--enable-zstd") "--enable-zstd")
#:phases #:phases
#~(modify-phases %standard-phases #~(modify-phases %standard-phases