gnu: Add aws-c-event-stream.
* gnu/packages/c.scm (aws-c-event-stream): New variable. * gnu/packages/patches/aws-c-event-stream-cmake-prefix.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
This commit is contained in:
parent
4c66a8deb5
commit
ddab5244df
3 changed files with 41 additions and 0 deletions
|
@ -823,6 +823,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/avogadro-python-eigen-lib.patch \
|
||||
%D%/packages/patches/avidemux-install-to-lib.patch \
|
||||
%D%/packages/patches/awesome-reproducible-png.patch \
|
||||
%D%/packages/patches/aws-c-event-stream-cmake-prefix.patch \
|
||||
%D%/packages/patches/aws-checksums-cmake-prefix.patch \
|
||||
%D%/packages/patches/azr3.patch \
|
||||
%D%/packages/patches/bash-reproducible-linux-pgrp-pipe.patch \
|
||||
|
|
|
@ -584,3 +584,30 @@ (define-public aws-checksums
|
|||
with fallback to efficient C99 software implementations.")
|
||||
(home-page "https://github.com/awslabs/aws-checksums")
|
||||
(license license:asl2.0)))
|
||||
|
||||
(define-public aws-c-event-stream
|
||||
(package
|
||||
(name "aws-c-event-stream")
|
||||
(version "0.1.6")
|
||||
(source (origin
|
||||
(method git-fetch)
|
||||
(uri (git-reference
|
||||
(url (string-append "https://github.com/awslabs/" name))
|
||||
(commit (string-append "v" version))))
|
||||
(file-name (git-file-name name version))
|
||||
(sha256
|
||||
(base32
|
||||
"1vl9ainc4klv0g9gk1iv4833bsllni6jxn6mwb0fnv2dnlz7zv9q"))
|
||||
(patches (search-patches "aws-c-event-stream-cmake-prefix.patch"))))
|
||||
(build-system cmake-build-system)
|
||||
(propagated-inputs
|
||||
`(("aws-c-common" ,aws-c-common)))
|
||||
(inputs
|
||||
`(("aws-checksums" ,aws-checksums)))
|
||||
(synopsis "Amazon Web Services client-server message format library")
|
||||
(description
|
||||
"This library is a C99 implementation for @acronym{AWS,Amazon Web Services}
|
||||
event stream encoding, a binary format for bidirectional client-server
|
||||
communication.")
|
||||
(home-page "https://github.com/awslabs/aws-c-event-stream")
|
||||
(license license:asl2.0)))
|
||||
|
|
13
gnu/packages/patches/aws-c-event-stream-cmake-prefix.patch
Normal file
13
gnu/packages/patches/aws-c-event-stream-cmake-prefix.patch
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -3,6 +3,10 @@
|
||||
cmake_minimum_required (VERSION 3.1)
|
||||
project (aws-c-event-stream C)
|
||||
|
||||
+if (DEFINED ENV{CMAKE_PREFIX_PATH})
|
||||
+ set(CMAKE_PREFIX_PATH $ENV{CMAKE_PREFIX_PATH})
|
||||
+endif()
|
||||
+
|
||||
if (DEFINED CMAKE_PREFIX_PATH)
|
||||
file(TO_CMAKE_PATH "${CMAKE_PREFIX_PATH}" CMAKE_PREFIX_PATH)
|
||||
endif()
|
Loading…
Reference in a new issue