gnu: notmuch: Update to 0.23.1.
* gnu/packages/patches/notmuch-emacs-25-compatibility-fix.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it. * gnu/packages/mail.scm (notmuch): Update to 0.23.1. Remove patch.
This commit is contained in:
parent
8f5f6c922f
commit
d2a9b531fb
3 changed files with 2 additions and 53 deletions
|
@ -728,7 +728,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/ninja-tests.patch \
|
||||
%D%/packages/patches/ninja-zero-mtime.patch \
|
||||
%D%/packages/patches/node-9077.patch \
|
||||
%D%/packages/patches/notmuch-emacs-25-compatibility-fix.patch \
|
||||
%D%/packages/patches/nss-pkgconfig.patch \
|
||||
%D%/packages/patches/nvi-assume-preserve-path.patch \
|
||||
%D%/packages/patches/nvi-dbpagesize-binpower.patch \
|
||||
|
|
|
@ -501,18 +501,14 @@ (define-public notifymuch
|
|||
(define-public notmuch
|
||||
(package
|
||||
(name "notmuch")
|
||||
(version "0.23")
|
||||
(version "0.23.1")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "https://notmuchmail.org/releases/notmuch-"
|
||||
version ".tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"1f51l34rdhjf8lvafrwybkxdsdwx8k9397m7qxd8rdg2irjmpry5"))
|
||||
(patches
|
||||
;; Remove this for the next release. See this thread for context:
|
||||
;; https://notmuchmail.org/pipermail/notmuch/2016/023227.html
|
||||
(search-patches "notmuch-emacs-25-compatibility-fix.patch"))))
|
||||
"106ijsnilqf8760z4cq99rqzjsvyaw86d0lgnzz7v95gm4d2l0g8"))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
'(#:make-flags (list "V=1") ; Verbose test output.
|
||||
|
|
|
@ -1,46 +0,0 @@
|
|||
This fixes a test failure with emacs-25. Picked from
|
||||
https://git.notmuchmail.org/git?p=notmuch;a=commit;h=f575a346df09c82691bb9e7c462836d982fe31f7
|
||||
|
||||
From f575a346df09c82691bb9e7c462836d982fe31f7 Mon Sep 17 00:00:00 2001
|
||||
From: David Bremner <david@tethera.net>
|
||||
Date: Sun, 9 Oct 2016 19:30:44 -0300
|
||||
Subject: [PATCH] emacs/show: force notmuch-show-buttonise-links to act on
|
||||
lines
|
||||
|
||||
This seems to fix a problem with emacs 25 creating partial buttons by
|
||||
calling n-s-b-l with a region that does not include the whole button.
|
||||
I'm not 100% sure it's legit to act outside the region passed by
|
||||
jit-lock, but goto-address-fontify-region (where I borrowed the code
|
||||
from) already does this, so this patch to not make things worse.
|
||||
---
|
||||
emacs/notmuch-show.el | 12 +++++++-----
|
||||
1 file changed, 7 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/emacs/notmuch-show.el b/emacs/notmuch-show.el
|
||||
index 641398d..e7d16f8 100644
|
||||
--- a/emacs/notmuch-show.el
|
||||
+++ b/emacs/notmuch-show.el
|
||||
@@ -1174,13 +1174,15 @@ This also turns id:\"<message id>\"-parts and mid: links into
|
||||
buttons for a corresponding notmuch search."
|
||||
(goto-address-fontify-region start end)
|
||||
(save-excursion
|
||||
- (let (links)
|
||||
- (goto-char start)
|
||||
- (while (re-search-forward notmuch-id-regexp end t)
|
||||
+ (let (links
|
||||
+ (beg-line (progn (goto-char start) (line-beginning-position)))
|
||||
+ (end-line (progn (goto-char end) (line-end-position))))
|
||||
+ (goto-char beg-line)
|
||||
+ (while (re-search-forward notmuch-id-regexp end-line t)
|
||||
(push (list (match-beginning 0) (match-end 0)
|
||||
(match-string-no-properties 0)) links))
|
||||
- (goto-char start)
|
||||
- (while (re-search-forward notmuch-mid-regexp end t)
|
||||
+ (goto-char beg-line)
|
||||
+ (while (re-search-forward notmuch-mid-regexp end-line t)
|
||||
(let* ((mid-cid (match-string-no-properties 1))
|
||||
(mid (save-match-data
|
||||
(string-match "^[^/]*" mid-cid)
|
||||
--
|
||||
2.10.1
|
||||
|
Loading…
Reference in a new issue