gnu: meson: Update to 0.46.0.
* gnu/packages/build-tools.scm (meson): Update to 0.46.0. * gnu/packages/patches/meson-for-build-rpath.patch: Adapt.
This commit is contained in:
parent
d54303215e
commit
cf0d6d8367
2 changed files with 5 additions and 6 deletions
|
@ -98,7 +98,7 @@ (define-public bear
|
|||
(define-public meson
|
||||
(package
|
||||
(name "meson")
|
||||
(version "0.45.1")
|
||||
(version "0.46.0")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "https://github.com/mesonbuild/meson/"
|
||||
|
@ -106,7 +106,7 @@ (define-public meson
|
|||
version ".tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"1yqa4337nb8w92bvr91rsxmn0xkf7pmdybq9ljvnqmdvn7dv02sd"))))
|
||||
"1w6bm43gy2swk3hmbarm0iv8m8yd8xm5jczsvfn8z2im3aq93pxp"))))
|
||||
(build-system python-build-system)
|
||||
(arguments
|
||||
`(;; FIXME: Tests require many additional inputs, a fix for the RUNPATH
|
||||
|
|
|
@ -6,14 +6,13 @@ Patch by Peter Mikkelsen <petermikkelsen10@gmail.com>
|
|||
|
||||
--- meson-0.42.0/mesonbuild/scripts/meson_install.py.orig 2017-09-09 01:49:39.147374148 +0200
|
||||
+++ meson-0.42.0/mesonbuild/scripts/meson_install.py 2017-09-09 01:51:01.209134717 +0200
|
||||
@@ -345,15 +345,6 @@
|
||||
@@ -391,14 +391,6 @@
|
||||
print("Symlink creation does not work on this platform. "
|
||||
"Skipping all symlinking.")
|
||||
printed_symlink_error = True
|
||||
- if is_elf_platform() and os.path.isfile(outname):
|
||||
- if os.path.isfile(outname):
|
||||
- try:
|
||||
- e = depfixer.Elf(outname, False)
|
||||
- e.fix_rpath(install_rpath)
|
||||
- depfixer.fix_rpath(outname, install_rpath, False)
|
||||
- except SystemExit as e:
|
||||
- if isinstance(e.code, int) and e.code == 0:
|
||||
- pass
|
||||
|
|
Loading…
Reference in a new issue