gnu: QEMU: Update to 6.0.0.

* gnu/packages/patches/qemu-build-info-manual.patch: Adjust for 6.0.
* gnu/packages/virtualization.scm (qemu): Update to 6.0.0.
[source](snippet): Remove obsolete substitution.
[arguments]: Adjust test substitutions for upstream changes.
* gnu/packages/bootloaders.scm (grub)[source](modules, snippet): New fields.
This commit is contained in:
Marius Bakke 2021-06-13 14:44:06 +02:00
parent 245cab2abc
commit c87ebc1b31
No known key found for this signature in database
GPG key ID: A2A06DF2A33A54FA
3 changed files with 31 additions and 54 deletions

View file

@ -3,7 +3,7 @@
;;; Copyright © 2015, 2018 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016, 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2016, 2017, 2018 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2016, 2017, 2018, 2021 Marius Bakke <marius@gnu.org>
;;; Copyright © 2016, 2017 Danny Milosavljevic <dannym@scratchpost.org>
;;; Copyright © 2016, 2017 David Craven <david@craven.ch>
;;; Copyright © 2017, 2018, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
@ -97,7 +97,15 @@ (define-public grub
"1qbycnxkx07arj9f2nlsi9kp0dyldspbv07ysdyd34qvz55a97mp"))
(patches (search-patches
"grub-efi-fat-serial-number.patch"
"grub-setup-root.patch"))))
"grub-setup-root.patch"))
(modules '((guix build utils)))
(snippet
'(begin
;; Adjust QEMU invocation to not use a deprecated device
;; name that was removed in QEMU 6.0. Remove for >2.06.
(substitute* "tests/ahci_test.in"
(("ide-drive")
"ide-hd"))))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags

View file

@ -13,17 +13,11 @@ configuring the directory under which the info manuals are installed.
* docs/meson.build (texi, info): New targets.
Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
---
configure | 7 ++++++-
docs/meson.build | 21 +++++++++++++++++++++
meson.build | 2 ++
3 files changed, 29 insertions(+), 1 deletion(-)
diff --git a/configure b/configure
index 18c26e0389..d1ab2c19d1 100755
--- a/configure
+++ b/configure
@@ -948,6 +948,8 @@ for opt do
@@ -951,6 +951,8 @@ for opt do
static="yes"
QEMU_PKG_CONFIG_FLAGS="--static $QEMU_PKG_CONFIG_FLAGS"
;;
@ -32,7 +26,7 @@ index 18c26e0389..d1ab2c19d1 100755
--mandir=*) mandir="$optarg"
;;
--bindir=*) bindir="$optarg"
@@ -975,7 +977,7 @@ for opt do
@@ -978,7 +980,7 @@ for opt do
--host=*|--build=*|\
--disable-dependency-tracking|\
--sbindir=*|--sharedstatedir=*|\
@ -41,35 +35,26 @@ index 18c26e0389..d1ab2c19d1 100755
--htmldir=*|--dvidir=*|--pdfdir=*|--psdir=*)
# These switches are silently ignored, for compatibility with
# autoconf-generated configure scripts. This allows QEMU's
@@ -1540,6 +1542,7 @@ includedir="${includedir:-$prefix/include}"
if test "$mingw32" = "yes" ; then
mandir="$prefix"
datadir="$prefix"
+ infodir="$prefix"
docdir="$prefix"
bindir="$prefix"
sysconfdir="$prefix"
@@ -1547,6 +1550,7 @@ if test "$mingw32" = "yes" ; then
else
mandir="${mandir:-$prefix/share/man}"
datadir="${datadir:-$prefix/share}"
+ infodir="${infodir:-$datadir/info}"
docdir="${docdir:-$prefix/share/doc}"
bindir="${bindir:-$prefix/bin}"
sysconfdir="${sysconfdir:-$prefix/etc}"
@@ -1683,6 +1687,7 @@ Advanced options (experts only):
--smbd=SMBD use specified smbd [$smbd]
--with-git=GIT use specified git [$git]
@@ -1599,6 +1601,7 @@ else
fi
mandir="${mandir:-$prefix/share/man}"
datadir="${datadir:-$prefix/share}"
+infodir="${infodir:-$datadir/info}"
docdir="${docdir:-$prefix/share/doc}"
sysconfdir="${sysconfdir:-$prefix/etc}"
local_statedir="${local_statedir:-$prefix/var}"
@@ -1736,6 +1739,7 @@ Advanced options (experts only):
--with-git-submodules=validate fail if git submodules are not up to date
--with-git-submodules=ignore do not update or check git submodules (default if no .git dir)
--static enable static build [$static]
+ --infodir=PATH install info manual in PATH
--mandir=PATH install man pages in PATH
--datadir=PATH install firmware in PATH/$qemu_suffix
--localedir=PATH install translation in PATH/$qemu_suffix
diff --git a/docs/meson.build b/docs/meson.build
index ebd85d59f9..1243839461 100644
--- a/docs/meson.build
+++ b/docs/meson.build
@@ -114,4 +114,25 @@ if build_docs
@@ -104,4 +104,25 @@ if build_docs
alias_target('sphinxdocs', sphinxdocs)
alias_target('html', sphinxdocs)
alias_target('man', sphinxmans)
@ -96,10 +81,9 @@ index ebd85d59f9..1243839461 100644
+ endif
endif
diff --git a/meson.build b/meson.build
index e3386196ba..d64a125ad9 100644
--- a/meson.build
+++ b/meson.build
@@ -32,6 +32,7 @@ endif
@@ -35,6 +35,7 @@ endif
qemu_confdir = get_option('sysconfdir') / get_option('qemu_suffix')
qemu_datadir = get_option('datadir') / get_option('qemu_suffix')
qemu_docdir = get_option('docdir') / get_option('qemu_suffix')
@ -107,14 +91,11 @@ index e3386196ba..d64a125ad9 100644
qemu_moddir = get_option('libdir') / get_option('qemu_suffix')
qemu_desktopdir = get_option('datadir') / 'applications'
@@ -1995,6 +1996,7 @@ else
@@ -2433,6 +2434,7 @@ else
summary_info += {'local state directory': 'queried at runtime'}
endif
summary_info += {'Doc directory': get_option('docdir')}
+summary_info += {'Info directory': get_option('infodir')}
summary_info += {'Build directory': meson.current_build_dir()}
summary_info += {'Source path': meson.current_source_dir()}
summary_info += {'GIT binary': config_host['GIT']}
--
2.30.1
summary_info += {'GIT submodules': config_host['GIT_SUBMODULES']}

View file

@ -142,7 +142,7 @@ (define (qemu-patch commit file-name sha256-bv)
(define-public qemu
(package
(name "qemu")
(version "5.2.0")
(version "6.0.0")
(source
(origin
(method url-fetch)
@ -150,24 +150,12 @@ (define-public qemu
version ".tar.xz"))
(sha256
(base32
"1g0pvx4qbirpcn9mni704y03n3lvkmw2c0rbcwvydyr8ns4xh66b"))
"1f9hz8rf12jm8baa7kda34yl4hyl0xh0c4ap03krfjx23i3img47"))
(patches (search-patches "qemu-CVE-2021-20203.patch"
"qemu-build-info-manual.patch"))
(modules '((guix build utils)))
(snippet
'(begin
;; Fix a bug in the do_ioctl_ifconf() function of qemu to
;; make ioctl(…, SIOCGIFCONF, …) work for emulated 64 bit
;; architectures. The size of struct ifreq is handled
;; incorrectly.
;; https://lists.nongnu.org/archive/html/qemu-devel/2021-01/msg01545.html
(substitute* '("linux-user/syscall.c")
(("^([[:blank:]]*)const argtype ifreq_arg_type.*$" line indent)
(string-append line indent "const argtype ifreq_max_type[] = "
"{ MK_STRUCT(STRUCT_ifmap_ifreq) };\n"))
(("^([[:blank:]]*)target_ifreq_size[[:blank:]]=.*$" _ indent)
(string-append indent "target_ifreq_size = "
"thunk_type_size(ifreq_max_type, 0);")))
;; Delete the bundled meson copy.
(delete-file-recursively "meson")))))
(outputs '("out" "static" "doc")) ;5.3 MiB of HTML docs
@ -223,14 +211,14 @@ (define-public qemu
(string-append match "9")))))
(add-after 'unpack 'disable-unusable-tests
(lambda _
(substitute* "tests/meson.build"
(substitute* "tests/unit/meson.build"
;; Comment out the test-qga test, which needs /sys and
;; fails within the build environment.
(("tests.*test-qga.*$" all)
(string-append "# " all))
;; Comment out the test-char test, which needs networking and
;; fails within the build environment.
(("check-unit-.* tests/test-char" all)
((".*'test-char':.*" all)
(string-append "# " all)))))
(add-after 'patch-source-shebangs 'patch-embedded-shebangs
(lambda _