gnu: aws-sdk-cpp: Update to 1.9.136.

* gnu/packages/cpp.scm (aws-sdk-cpp): Update to 1.9.136.
[arguments]: Fix CMAKE_PREFIX_PATH.
[source]: Remove patches.
* gnu/packages/patches/aws-sdk-cpp-cmake-prefix.patch,
gnu/packages/patches/aws-sdk-cpp-disable-network-tests.patch,
gnu/packages/patches/aws-sdk-cpp-disable-werror.patch: Delete files.
* gnu/local.mk (dist_patch_DATA): Remove them.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
This commit is contained in:
Greg Hogan 2021-10-18 18:08:57 +00:00 committed by Ludovic Courtès
parent 37db6db284
commit c769b8c2b5
No known key found for this signature in database
GPG key ID: 090B11993D9AEBB5
5 changed files with 8 additions and 85 deletions

View file

@ -873,9 +873,6 @@ dist_patch_DATA = \
%D%/packages/patches/aws-c-auth-install-private-headers.patch \
%D%/packages/patches/aws-c-event-stream-cmake-prefix.patch \
%D%/packages/patches/aws-checksums-cmake-prefix.patch \
%D%/packages/patches/aws-sdk-cpp-cmake-prefix.patch \
%D%/packages/patches/aws-sdk-cpp-disable-networking-tests.patch \
%D%/packages/patches/aws-sdk-cpp-disable-werror.patch \
%D%/packages/patches/azr3.patch \
%D%/packages/patches/bash-reproducible-linux-pgrp-pipe.patch \
%D%/packages/patches/bash-completion-directories.patch \

View file

@ -943,7 +943,9 @@ (define-public aws-crt-cpp
(define-public aws-sdk-cpp
(package
(name "aws-sdk-cpp")
(version "1.9.92")
; When updating also check for a tagged update to aws-crt-cpp from
; https://github.com/aws/aws-sdk-cpp/tree/main/crt
(version "1.9.136")
(source (origin
(method git-fetch)
(uri (git-reference
@ -952,19 +954,16 @@ (define-public aws-sdk-cpp
(file-name (git-file-name name version))
(sha256
(base32
"0nbq1qivykfg8jmrn8d0k6fcfa5dw9s90wnwddh7ia4zafmby7pd"))
(patches
(search-patches
"aws-sdk-cpp-cmake-prefix.patch"
"aws-sdk-cpp-disable-networking-tests.patch"
"aws-sdk-cpp-disable-werror.patch"))))
"0ap7g7nmbnrcajy3b788bnpqd87dwmg83dhll1q8qzli04bcg47i"))))
(build-system cmake-build-system)
(arguments
'(;; Tests are run during the build phase.
#:tests? #f
#:configure-flags
'("-DBUILD_SHARED_LIBS=ON"
"-DBUILD_DEPS=OFF")))
(list "-DBUILD_DEPS=OFF"
"-DBUILD_SHARED_LIBS=ON"
(string-append "-DCMAKE_PREFIX_PATH="
(assoc-ref %build-inputs "aws-c-common")))))
(propagated-inputs
`(("aws-crt-cpp" ,aws-crt-cpp)))
(inputs

View file

@ -1,18 +0,0 @@
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -98,9 +98,13 @@ set(PYTHON_CMD "python")
# CMAKE_MODULE_PATH is a CMAKE variable. It contains a list of paths
# which could be used to search CMAKE modules by "include()" or "find_package()", but the default value is empty.
# Add ${CMAKE_INSTALL_LIBDIR}/cmake and ${CMAKE_PREFIX_PATH}/lib/cmake to search list
+if (DEFINED ENV{CMAKE_PREFIX_PATH})
+ set(CMAKE_PREFIX_PATH $ENV{CMAKE_PREFIX_PATH})
+endif()
+
list(APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_LIST_DIR}/cmake")
-set(AWS_MODULE_DIR "/${CMAKE_INSTALL_LIBDIR}/cmake")
-string(REPLACE ";" "${AWS_MODULE_DIR};" AWS_MODULE_PATH "${CMAKE_PREFIX_PATH}${AWS_MODULE_DIR}")
+set(AWS_MODULE_DIR "${CMAKE_INSTALL_LIBDIR}/cmake")
+string(REPLACE ":" "${AWS_MODULE_DIR};" AWS_MODULE_PATH "${CMAKE_PREFIX_PATH}${AWS_MODULE_DIR}")
list(APPEND CMAKE_MODULE_PATH ${AWS_MODULE_PATH})
# include() will "load and run" cmake script

View file

@ -1,44 +0,0 @@
--- a/aws-cpp-sdk-core-tests/http/HttpClientTest.cpp
+++ b/aws-cpp-sdk-core-tests/http/HttpClientTest.cpp
@@ -92,12 +92,12 @@ TEST(HttpClientTest, TestRandomURLWithNoProxy)
makeRandomHttpRequest(httpClient, false);
}
-TEST(HttpClientTest, TestRandomURLWithProxy)
-{
- ClientConfiguration configuration = makeClientConfigurationWithProxy();
- auto httpClient = CreateHttpClient(configuration);
- makeRandomHttpRequest(httpClient, true); // we expect it to try to use proxy that is invalid
-}
+//TEST(HttpClientTest, TestRandomURLWithProxy)
+//{
+// ClientConfiguration configuration = makeClientConfigurationWithProxy();
+// auto httpClient = CreateHttpClient(configuration);
+// makeRandomHttpRequest(httpClient, true); // we expect it to try to use proxy that is invalid
+//}
TEST(HttpClientTest, TestRandomURLWithProxyAndDeclaredAsNonProxyHost)
{
@@ -119,14 +119,14 @@ TEST(HttpClientTest, TestRandomURLWithProxyAndDeclaredParentDomainAsNonProxyHost
makeRandomHttpRequest(httpClient, false);
}
-TEST(HttpClientTest, TestRandomURLWithProxyAndOtherDeclaredAsNonProxyHost)
-{
- ClientConfiguration configuration = makeClientConfigurationWithProxy();
- configuration.nonProxyHosts = Aws::Utils::Array<Aws::String>(1);
- configuration.nonProxyHosts[0] = "http://test.non.filtered.aws";
- auto httpClient = CreateHttpClient(configuration);
- makeRandomHttpRequest(httpClient, true);
-}
+//TEST(HttpClientTest, TestRandomURLWithProxyAndOtherDeclaredAsNonProxyHost)
+//{
+// ClientConfiguration configuration = makeClientConfigurationWithProxy();
+// configuration.nonProxyHosts = Aws::Utils::Array<Aws::String>(1);
+// configuration.nonProxyHosts[0] = "http://test.non.filtered.aws";
+// auto httpClient = CreateHttpClient(configuration);
+// makeRandomHttpRequest(httpClient, true);
+//}
// TODO: Pending Fix on Windows.
#if ENABLE_CURL_CLIENT

View file

@ -1,11 +0,0 @@
--- a/cmake/compiler_settings.cmake
+++ b/cmake/compiler_settings.cmake
@@ -53,7 +53,7 @@ macro(set_gcc_flags)
endmacro()
macro(set_gcc_warnings)
- list(APPEND AWS_COMPILER_WARNINGS "-Wall" "-Werror" "-pedantic" "-Wextra")
+ list(APPEND AWS_COMPILER_WARNINGS "-Wall" "-pedantic" "-Wextra")
if(COMPILER_CLANG)
if(PLATFORM_ANDROID)
# when using clang with libc and API lower than 21 we need to include Android support headers and ignore the gnu-include-next warning.