gnu: libseccomp: Update to 2.4.3.
* gnu/packages/linux.scm (libseccomp): Update to 2.4.3. [source]: Remove upstreamed patch. * gnu/packages/patches/libseccomp-open-aarch64.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
parent
1fad0b8674
commit
c3bde0b7af
3 changed files with 2 additions and 31 deletions
|
@ -1114,7 +1114,6 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/libmpeg2-global-symbol-test.patch \
|
%D%/packages/patches/libmpeg2-global-symbol-test.patch \
|
||||||
%D%/packages/patches/libmygpo-qt-fix-qt-5.11.patch \
|
%D%/packages/patches/libmygpo-qt-fix-qt-5.11.patch \
|
||||||
%D%/packages/patches/libmygpo-qt-missing-qt5-modules.patch \
|
%D%/packages/patches/libmygpo-qt-missing-qt5-modules.patch \
|
||||||
%D%/packages/patches/libseccomp-open-aarch64.patch \
|
|
||||||
%D%/packages/patches/libsndfile-armhf-type-checks.patch \
|
%D%/packages/patches/libsndfile-armhf-type-checks.patch \
|
||||||
%D%/packages/patches/libsndfile-CVE-2017-8361-8363-8365.patch \
|
%D%/packages/patches/libsndfile-CVE-2017-8361-8363-8365.patch \
|
||||||
%D%/packages/patches/libsndfile-CVE-2017-8362.patch \
|
%D%/packages/patches/libsndfile-CVE-2017-8362.patch \
|
||||||
|
|
|
@ -5030,7 +5030,7 @@ (define-public mtd-utils
|
||||||
(define-public libseccomp
|
(define-public libseccomp
|
||||||
(package
|
(package
|
||||||
(name "libseccomp")
|
(name "libseccomp")
|
||||||
(version "2.4.2")
|
(version "2.4.3")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "https://github.com/seccomp/libseccomp/"
|
(uri (string-append "https://github.com/seccomp/libseccomp/"
|
||||||
|
@ -5038,8 +5038,7 @@ (define-public libseccomp
|
||||||
"/libseccomp-" version ".tar.gz"))
|
"/libseccomp-" version ".tar.gz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"0nsq81acrbkdr8zairxbwa33bj2a6126npp76b4srjl472sjfkxm"))
|
"07crwxqzvl5k2b90a47ii9wgvi09s9hsy5b5jddw9ylp351d25fg"))))
|
||||||
(patches (search-patches "libseccomp-open-aarch64.patch"))))
|
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(native-inputs
|
(native-inputs
|
||||||
`(("which" ,which)))
|
`(("which" ,which)))
|
||||||
|
|
|
@ -1,27 +0,0 @@
|
||||||
This patch fixes the build failure on AArch64 reported
|
|
||||||
at <https://github.com/seccomp/libseccomp/pull/191>.
|
|
||||||
|
|
||||||
From cc21c1b48d35f9d34ef2da0e184af3855bfeee5f Mon Sep 17 00:00:00 2001
|
|
||||||
From: =?UTF-8?q?Zbigniew=20J=C4=99drzejewski-Szmek?= <zbyszek@in.waw.pl>
|
|
||||||
Date: Wed, 20 Nov 2019 14:11:12 -0500
|
|
||||||
Subject: [PATCH] tests: use openat instead of open
|
|
||||||
|
|
||||||
On arm64, __NR_open is not defined, openat is always used. Let's use openat
|
|
||||||
instead, which is defined for architectures currently.
|
|
||||||
---
|
|
||||||
tests/15-basic-resolver.c | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/tests/15-basic-resolver.c b/tests/15-basic-resolver.c
|
|
||||||
index 6badef1..4884faf 100644
|
|
||||||
--- a/tests/15-basic-resolver.c
|
|
||||||
+++ b/tests/15-basic-resolver.c
|
|
||||||
@@ -55,7 +55,7 @@ int main(int argc, char *argv[])
|
|
||||||
unsigned int arch;
|
|
||||||
char *name = NULL;
|
|
||||||
|
|
||||||
- if (seccomp_syscall_resolve_name("open") != __NR_open)
|
|
||||||
+ if (seccomp_syscall_resolve_name("openat") != __NR_openat)
|
|
||||||
goto fail;
|
|
||||||
if (seccomp_syscall_resolve_name("read") != __NR_read)
|
|
||||||
goto fail;
|
|
Loading…
Reference in a new issue