gnu: spice: Update to 0.14.3.

* gnu/packages/spice.scm (spice): Update to 0.14.3.
[source]: Remove obsolete patch.
* gnu/packages/patches/spice-fix-test-armhf.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
Tobias Geerinckx-Rice 2020-03-07 12:02:22 +01:00
parent beecf815db
commit c0dc417909
No known key found for this signature in database
GPG key ID: 0DB0FF884F556D79
5 changed files with 6 additions and 27 deletions

View file

@ -1407,7 +1407,6 @@ dist_patch_DATA = \
%D%/packages/patches/snappy-add-O2-flag-in-CmakeLists.txt.patch \
%D%/packages/patches/sooperlooper-build-with-wx-30.patch \
%D%/packages/patches/soundconverter-remove-gconf-dependency.patch \
%D%/packages/patches/spice-fix-test-armhf.patch \
%D%/packages/patches/steghide-fixes.patch \
%D%/packages/patches/suitesparse-mongoose-cmake.patch \
%D%/packages/patches/superlu-dist-awpm-grid.patch \

View file

@ -1300,7 +1300,7 @@ (define-public zimg
(commit (string-append "release-" version))))
(file-name (git-file-name name version))
(sha256
(base32 "1dqyrq3p8bkgvj4ci50ac342hjnhyz6xxvhiwp7wpi3v3nbj7s02"))))
(base32 "12bs2rfmmy021087i10vxibdbbvd5vld0vk3h5hymhpz7rgszcmg"))))
(build-system gnu-build-system)
(native-inputs
`(("autoconf" ,autoconf)

View file

@ -1,19 +0,0 @@
Fix test failure on armhf and ppc64el:
https://gitlab.freedesktop.org/spice/spice-server/issues/31
Taken from upstream:
https://gitlab.freedesktop.org/spice/spice/commit/19f9f454e0777d851f26d14df0c7984267c57015
diff --git a/server/tests/test-qxl-parsing.c b/server/tests/test-qxl-parsing.c
index 60ca8f88c62441e02577ced21e4f60a08ad4171a..234bdabc9ce619d0799b5136f1d72357b0b2f490 100644
--- a/server/tests/test-qxl-parsing.c
+++ b/server/tests/test-qxl-parsing.c
@@ -96,7 +96,7 @@ static void test_memslot_invalid_slot_id(void)
RedMemSlotInfo mem_info;
init_meminfo(&mem_info);
- memslot_get_virt(&mem_info, 1 << mem_info.memslot_id_shift, 16, 0);
+ memslot_get_virt(&mem_info, UINT64_C(1) << mem_info.memslot_id_shift, 16, 0);
}
static void test_memslot_invalid_addresses(void)

View file

@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 David Craven <david@craven.ch>
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
;;;
@ -191,16 +191,15 @@ (define-public spice-gtk
(define-public spice
(package
(name "spice")
(version "0.14.2")
(version "0.14.3")
(source (origin
(method url-fetch)
(uri (string-append
"https://www.spice-space.org/download/releases/"
"spice-server/spice-" version ".tar.bz2"))
(patches (search-patches "spice-fix-test-armhf.patch"))
(sha256
(base32
"19r999py9v9c7md2bb8ysj809ag1hh6djl1ik8jcgx065s4b60xj"))))
"05512vkfayw18ypg4acqbbpr72nsnsz9bj7k8c2wyrvnl3j4n7am"))))
(build-system gnu-build-system)
(propagated-inputs
`(("openssl" ,openssl)

View file

@ -1548,7 +1548,7 @@ (define-public libvpx-1.7
(define-public youtube-dl
(package
(name "youtube-dl")
(version "2020.02.16")
(version "2020.03.06")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/ytdl-org/youtube-dl/"
@ -1556,7 +1556,7 @@ (define-public youtube-dl
version ".tar.gz"))
(sha256
(base32
"1ip0p7gifwmkls8ppfvz89j1lh82dg60zmvabj8njnhj170ikkdb"))))
"16c10rgkjrjv115w4r7gsr9hcakqq5s2cg250b1hwvxdsxqp8vnv"))))
(build-system python-build-system)
(arguments
;; The problem here is that the directory for the man page and completion