gnu: rust-openssl-sys-0.9: Update to 0.9.84.

* gnu/packages/crates-io.scm (rust-openssl-sys-0.9): Update to 0.9.84.
[arguments]: Replace rust-bindgen-0.59 cargo-input with rust-bindgen-0.64.
* gnu/packages/patches/rust-openssl-sys-no-vendor.patch: Update patch.
This commit is contained in:
Maxim Cournoyer 2023-04-03 09:20:03 -04:00
parent b1ac3eecc5
commit bea4d27948
No known key found for this signature in database
GPG key ID: 1260E46482E63562
2 changed files with 21 additions and 15 deletions

View file

@ -38552,14 +38552,14 @@ (define-public rust-openssl-probe-0.1
(define-public rust-openssl-sys-0.9
(package
(name "rust-openssl-sys")
(version "0.9.75")
(version "0.9.84")
(source
(origin
(method url-fetch)
(uri (crate-uri "openssl-sys" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32 "0bxlrsfkvryv179na416mvj0s90v9yngkmkkv8y1lm0h4w6bvyg5"))
(base32 "1ym0vcfnyp8bf8lidz8w0yx0n6pva37nvdww0c22kn62kp7fl81s"))
(patches (search-patches "rust-openssl-sys-no-vendor.patch"))))
(build-system cargo-build-system)
(arguments
@ -38567,7 +38567,7 @@ (define-public rust-openssl-sys-0.9
(("rust-libc" ,rust-libc-0.2)
;; Build dependencies:
("rust-autocfg" ,rust-autocfg-1)
("rust-bindgen" ,rust-bindgen-0.59)
("rust-bindgen" ,rust-bindgen-0.64)
("rust-cc" ,rust-cc-1)
("rust-pkg-config" ,rust-pkg-config-0.3)
("rust-vcpkg" ,rust-vcpkg-0.2))))

View file

@ -1,12 +1,17 @@
https://sources.debian.org/data/main/r/rust-openssl-sys/0.9.53-1/debian/patches/disable-vendor.patch
"MIT" licensed according to debian/copyright file
slightly modified to only change the vendored openssl-src dependency
--- openssl-sys-0.9.84/Cargo.toml.orig 2023-04-03 09:10:11.979197979 -0400
+++ openssl-sys-0.9.84/Cargo.toml 2023-04-03 12:07:30.285315609 -0400
@@ -31,10 +31,6 @@
[package.metadata.pkg-config]
openssl = "1.0.1"
Starting from rust-openssl-sys@0.9.69 Cargo.toml starts searching for openssl-3.0.
-[dependencies.bssl-sys]
-version = "0.1.0"
-optional = true
-
[dependencies.libc]
version = "0.2"
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -31,15 +31,12 @@
@@ -46,16 +42,12 @@
[build-dependencies.cc]
version = "1.0"
@ -18,9 +23,10 @@ Starting from rust-openssl-sys@0.9.69 Cargo.toml starts searching for openssl-3.
version = "0.3.9"
[features]
vendored = ["openssl-src"]
+openssl-src = []
-unstable_boringssl = ["bssl-sys"]
-vendored = ["openssl-src"]
+unstable_boringssl = []
+vendored = []
[target."cfg(target_env = \"msvc\")".build-dependencies.vcpkg]
version = "0.2.8"