gnu: tor: Update to 0.4.7.7.
* gnu/packages/tor.scm (tor): Update to 0.4.7.7. [source]: Remove patch. * gnu/packages/patches/tor-sandbox-i686.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
parent
51b716f7f2
commit
be6d5783ba
3 changed files with 2 additions and 40 deletions
|
@ -1860,7 +1860,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/tlf-support-hamlib-4.2+.patch \
|
||||
gnu/packages/patches/tootle-glib-object-naming.patch \
|
||||
gnu/packages/patches/tootle-reason-phrase.patch \
|
||||
%D%/packages/patches/tor-sandbox-i686.patch \
|
||||
%D%/packages/patches/transcode-ffmpeg.patch \
|
||||
%D%/packages/patches/transfig-gcc10-fno-common.patch \
|
||||
%D%/packages/patches/transmission-honor-localedir.patch \
|
||||
|
|
|
@ -1,36 +0,0 @@
|
|||
This patch fixes sandboxing on i686 by allowing 'statx'. Without this,
|
||||
'src/test/test_include.sh' would fail.
|
||||
|
||||
Patch adapted from:
|
||||
|
||||
https://gitlab.torproject.org/tpo/core/tor/-/merge_requests/480
|
||||
|
||||
From 001d880d1082f5d124e10554e2718e407c7e88c6 Mon Sep 17 00:00:00 2001
|
||||
From: Simon South <simon@simonsouth.net>
|
||||
Date: Fri, 5 Nov 2021 10:10:10 -0400
|
||||
Subject: [PATCH] sandbox: Allow "statx" syscall on i386 for glibc 2.33
|
||||
|
||||
glibc versions 2.33 and newer use the modern "statx" system call in their
|
||||
implementations of stat() and opendir() for Linux on i386. Prevent failures in
|
||||
the sandbox unit tests by modifying the sandbox to allow this system call
|
||||
without restriction on i386 when it is available, and update the test suite to
|
||||
skip the "sandbox/stat_filename" test in this case as it is certain to fail.
|
||||
---
|
||||
src/lib/sandbox/sandbox.c | 3 +++
|
||||
src/test/test_sandbox.c | 7 ++++---
|
||||
2 files changed, 7 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/src/lib/sandbox/sandbox.c b/src/lib/sandbox/sandbox.c
|
||||
index fb02a345ab..a15f99ad76 100644
|
||||
--- a/src/lib/sandbox/sandbox.c
|
||||
+++ b/src/lib/sandbox/sandbox.c
|
||||
@@ -252,6 +252,9 @@ static int filter_nopar_gen[] = {
|
||||
SCMP_SYS(sigreturn),
|
||||
#endif
|
||||
SCMP_SYS(stat),
|
||||
+#if defined(__i386__) && defined(__NR_statx)
|
||||
+ SCMP_SYS(statx),
|
||||
+#endif
|
||||
SCMP_SYS(uname),
|
||||
SCMP_SYS(wait4),
|
||||
SCMP_SYS(write),
|
|
@ -57,15 +57,14 @@ (define-module (gnu packages tor)
|
|||
(define-public tor
|
||||
(package
|
||||
(name "tor")
|
||||
(version "0.4.6.10")
|
||||
(version "0.4.7.7")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "https://dist.torproject.org/tor-"
|
||||
version ".tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"077374vqk9mxi63viksq5zwn05i4xa2bqcihwwxz6n750h7ddk4l"))
|
||||
(patches (search-patches "tor-sandbox-i686.patch"))))
|
||||
"0i2v3a2h7d0bjn64pi1c6h2x15lb53plf71xwkbkb51bnmc124ry"))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
`(#:configure-flags
|
||||
|
|
Loading…
Reference in a new issue