gnu: geoclue: Update to 2.6.0 and remove input labels.

* gnu/packages/gnome.scm (geoclue): Update to 2.6.0.
[native-inputs]: Replace intltool with gettext-minimal.  Add vala.
[inputs]: Delete labels.
* gnu/packages/patches/geoclue-config.patch: Refresh patch.
This commit is contained in:
Maxim Cournoyer 2022-08-22 21:14:16 -04:00
parent 5f7b0141d6
commit bbe444bcc1
No known key found for this signature in database
GPG key ID: 1260E46482E63562
2 changed files with 24 additions and 23 deletions

View file

@ -5393,7 +5393,7 @@ (define-public colord
(define-public geoclue
(package
(name "geoclue")
(version "2.5.7")
(version "2.6.0")
(source
(origin
(method url-fetch)
@ -5401,7 +5401,7 @@ (define-public geoclue
(string-append "https://gitlab.freedesktop.org/geoclue/geoclue/-/archive/"
version "/geoclue-" version ".tar.bz2"))
(sha256
(base32 "09ww26a76kanldhgwnn5sqy9ly2940k45zpp68spykkv2zjdpivc"))
(base32 "1854i8lih1jkks5w38xv8k5gs7s8629qjg3cg96ji0ffk35yzjfd"))
(patches (search-patches "geoclue-config.patch"))))
(build-system meson-build-system)
(arguments
@ -5412,13 +5412,14 @@ (define-public geoclue
modem-manager
libnotify
gtk-doc/stable
intltool))
gettext-minimal
vala))
(inputs
`(("avahi" ,avahi)
("glib:bin" ,glib "bin")
("glib-networking" ,glib-networking)
("json-glib" ,json-glib)
("libsoup" ,libsoup-minimal-2)))
(list avahi
`(,glib "bin")
glib-networking
json-glib
libsoup-minimal-2))
(home-page "https://gitlab.freedesktop.org/geoclue/geoclue/-/wikis/home")
(synopsis "Geolocation service")
(description "Geoclue is a D-Bus service that provides location

View file

@ -1,25 +1,25 @@
Allow the configuration file to be specified via an environment variable.
--- geoclue-2.1.10/src/gclue-config.c 2015-04-07 09:50:07.721074380 +0200
+++ geoclue-2.1.10/src/gclue-config.c 2015-04-07 10:27:26.613171960 +0200
@@ -235,6 +235,11 @@
diff --git a/src/gclue-config.c b/src/gclue-config.c
index 7ab2a67..e41f3df 100644
--- a/src/gclue-config.c
+++ b/src/gclue-config.c
@@ -332,6 +332,11 @@ static void
gclue_config_init (GClueConfig *config)
{
GError *error = NULL;
+ const char *config_file_path;
+
+ config_file_path = g_getenv ("GEOCLUE_CONFIG_FILE");
+ if (config_file_path == NULL)
+ config_file_path = CONFIG_FILE_PATH;
+ if (!config_file_path)
+ config_file_path = CONFIG_FILE_PATH;
config->priv =
G_TYPE_INSTANCE_GET_PRIVATE (config,
@@ -242,7 +247,7 @@
GClueConfigPrivate);
config->priv = gclue_config_get_instance_private(config);
config->priv->key_file = g_key_file_new ();
g_key_file_load_from_file (config->priv->key_file,
- CONFIG_FILE_PATH,
+ config_file_path,
0,
@@ -341,7 +346,7 @@ gclue_config_init (GClueConfig *config)
&error);
if (error != NULL) {
g_critical ("Failed to load configuration file '%s': %s",
- CONFIG_FILE_PATH, error->message);
+ config_file_path, error->message);
g_error_free (error);
return;