gnu: Add wacomtablet.

* gnu/packages/kde-utils.scm (wacomtablet): New variable.

Signed-off-by: Marius Bakke <marius@gnu.org>
This commit is contained in:
Petr Hodina 2022-08-23 12:55:28 +02:00 committed by Marius Bakke
parent 4bc8c1ec9d
commit b2a2f566aa
No known key found for this signature in database
GPG Key ID: A2A06DF2A33A54FA
4 changed files with 83 additions and 0 deletions

View File

@ -1990,6 +1990,8 @@ dist_patch_DATA = \
%D%/packages/patches/vtk-7-gcc-10-compat.patch \
%D%/packages/patches/vtk-7-hdf5-compat.patch \
%D%/packages/patches/vtk-7-python-compat.patch \
%D%/packages/patches/wacomtablet-add-missing-includes.patch \
%D%/packages/patches/wacomtablet-qt5.15.patch \
%D%/packages/patches/warsow-qfusion-fix-bool-return-type.patch \
%D%/packages/patches/webkitgtk-adjust-bubblewrap-paths.patch \
%D%/packages/patches/webrtc-audio-processing-big-endian.patch \

View File

@ -22,6 +22,7 @@
(define-module (gnu packages kde-utils)
#:use-module (guix build-system qt)
#:use-module (guix gexp)
#:use-module (guix download)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
@ -30,6 +31,7 @@
#:use-module (gnu packages bash)
#:use-module (gnu packages cmake)
#:use-module (gnu packages compression)
#:use-module (gnu packages glib) ; dbus for tests
#:use-module (gnu packages gnome)
#:use-module (gnu packages imagemagick)
#:use-module (gnu packages pkg-config)
@ -38,6 +40,7 @@
#:use-module (gnu packages kde-plasma)
#:use-module (gnu packages qt)
#:use-module (gnu packages samba)
#:use-module (gnu packages xdisorg)
#:use-module (gnu packages xorg))
(define-public ark
@ -180,6 +183,50 @@ Kate's features include:
(license ;; GPL for programs, LGPL for libraries
(list license:gpl2+ license:lgpl2.0))))
(define-public wacomtablet
(package
(name "wacomtablet")
(version "3.2.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://kde/stable/"
name "/" version "/"
name "-" version ".tar.xz"))
(patches (search-patches
"wacomtablet-add-missing-includes.patch"
"wacomtablet-qt5.15.patch"))
(sha256
(base32
"197pwpl87gqlnza36bp68jvw8ww25znk08acmi8bpz7n84xfc368"))))
(build-system qt-build-system)
(arguments
(list #:phases #~(modify-phases %standard-phases
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(when tests?
(invoke "dbus-launch" "ctest" "-E"
"(Test.KDED.DBusTabletService|Test.KDED.TabletHandler|Test.KDED.XInputAdaptor|Test.KDED.XsetWacomAdaptor)")))))))
(native-inputs (list dbus extra-cmake-modules kdoctools pkg-config))
(inputs (list kcoreaddons
ki18n
kglobalaccel
kconfig
kxmlgui
kwidgetsaddons
kwindowsystem
knotifications
kdbusaddons
qtx11extras
qtdeclarative-5
libwacom
xf86-input-wacom
libxi))
(propagated-inputs (list plasma-framework))
(home-page "https://invent.kde.org/system/wacomtablet")
(synopsis "KDE GUI for the Wacom Linux Drivers")
(description "Provides KDE GUI for the Wacom Linux Drivers.")
(license license:gpl2+)))
(define-public kmag
(package
(name "kmag")

View File

@ -0,0 +1,11 @@
diff -rup wacomtablet-3.1.0/src/kcmodule/styluspagewidget.cpp wacomtablet-3.1.0.new/src/kcmodule/styluspagewidget.cpp
--- wacomtablet-3.1.0/src/kcmodule/styluspagewidget.cpp 2018-06-22 15:07:58.000000000 +0200
+++ wacomtablet-3.1.0.new/src/kcmodule/styluspagewidget.cpp 2018-07-10 17:38:09.239242847 +0200
@@ -25,6 +25,7 @@
#include "profilemanagement.h"
// common includes
+#include "logging.h"
#include "property.h"
#include "deviceprofile.h"
#include "dbustabletinterface.h"

View File

@ -0,0 +1,23 @@
From 4f73ff02b3efd5e8728b18fcf1067eca166704ee Mon Sep 17 00:00:00 2001
From: Christophe Giboudeaux <christophe@krop.fr>
Date: Thu, 4 Jun 2020 16:00:38 +0200
Subject: [PATCH] Fix build with Qt 5.15
---
src/kcmodule/pressurecurvewidget.cpp | 1 +
1 file changed, 1 insertion(+)
diff --git a/src/kcmodule/pressurecurvewidget.cpp b/src/kcmodule/pressurecurvewidget.cpp
index 0c943b3..f047a6c 100644
--- a/src/kcmodule/pressurecurvewidget.cpp
+++ b/src/kcmodule/pressurecurvewidget.cpp
@@ -22,6 +22,7 @@
//Qt includes
#include <QDebug>
#include <QPainter>
+#include <QPainterPath>
#include <QMouseEvent>
#include <QResizeEvent>
#include <QTabletEvent>
--
GitLab