gnu: boost: Update to 1.76.0.

* gnu/packages/patches/boost-fix-transitive-linking.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/boost.scm (boost): Update to 1.76.0.
[source](patches): Remove.
This commit is contained in:
Marius Bakke 2021-05-16 11:32:39 +02:00
parent 52f4ba9617
commit b08d989045
No known key found for this signature in database
GPG key ID: A2A06DF2A33A54FA
3 changed files with 2 additions and 21 deletions

View file

@ -879,7 +879,6 @@ dist_patch_DATA = \
%D%/packages/patches/blender-2.79-oiio2.patch \
%D%/packages/patches/blender-2.79-python-3.7-fix.patch \
%D%/packages/patches/blender-2.79-python-3.8-fix.patch \
%D%/packages/patches/boost-fix-transitive-linking.patch \
%D%/packages/patches/bpftrace-disable-bfd-disasm.patch \
%D%/packages/patches/byobu-writable-status.patch \
%D%/packages/patches/cairo-CVE-2018-19876.patch \

View file

@ -66,17 +66,15 @@ (define (boost-patch name version hash)
(define-public boost
(package
(name "boost")
(version "1.75.0")
(version "1.76.0")
(source (origin
(method url-fetch)
(uri (string-append "https://boostorg.jfrog.io/artifactory/main/release/"
version "/source/boost_"
(version-with-underscores version) ".tar.bz2"))
; Should be included in next Boost update
(patches (search-patches "boost-fix-transitive-linking.patch"))
(sha256
(base32
"1js9zpij58l60kx46s3lxdp5207igppjnhqigwhbpdvd04gb6gcm"))))
"0hcc661savk32hx65997p0ss1awj6ala4cmz4w7lbi42x6k7nfgh"))))
(build-system gnu-build-system)
(inputs `(("icu4c" ,icu4c)
("zlib" ,zlib)))

View file

@ -1,16 +0,0 @@
Patch from https://github.com/boostorg/boost_install/issues/47
which should be included in the Boost 1.76 release.
This patch prevents CMake from explicitly linking against Boost dependencies
when building against the shared Boost libraries.
--- a/tools/boost_install/boost-install.jam
+++ b/tools/boost_install/boost-install.jam
@@ -483,7 +483,7 @@ rule generate-cmake-variant- ( target : sources * : properties * )
.info " deps3=" $(deps3) ;
- if $(deps3)
+ if $(deps3) && $(link) = static
{
print.text