gnu: ganeti: Update to 3.0.2.

* gnu/packages/patches/ganeti-haskell-compat.patch,
gnu/packages/patches/ganeti-sphinx-compat.patch: Delete files.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/virtualization.scm (ganeti): Update to 3.0.2.
[source](patches): Remove obsolete.
[arguments]: Remove obsolete phases.  Disable one more test.
This commit is contained in:
Marius Bakke 2022-04-09 14:19:23 +02:00
parent dce0249f18
commit aa5716703f
No known key found for this signature in database
GPG key ID: A2A06DF2A33A54FA
4 changed files with 3 additions and 62 deletions

View file

@ -1082,12 +1082,10 @@ dist_patch_DATA = \
%D%/packages/patches/fxdiv-system-libraries.patch \
%D%/packages/patches/gajim-honour-GAJIM_PLUGIN_PATH.patch \
%D%/packages/patches/ganeti-disable-version-symlinks.patch \
%D%/packages/patches/ganeti-haskell-compat.patch \
%D%/packages/patches/ganeti-haskell-pythondir.patch \
%D%/packages/patches/ganeti-pyyaml-compat.patch \
%D%/packages/patches/ganeti-shepherd-master-failover.patch \
%D%/packages/patches/ganeti-shepherd-support.patch \
%D%/packages/patches/ganeti-sphinx-compat.patch \
%D%/packages/patches/gash-utils-ls-test.patch \
%D%/packages/patches/gawk-shell.patch \
%D%/packages/patches/gcc-arm-bug-71399.patch \

View file

@ -1,18 +0,0 @@
Adjust to type change of TupE in Template Haskell 2.16.
diff --git a/src/Ganeti/THH/Types.hs b/src/Ganeti/THH/Types.hs
--- a/src/Ganeti/THH/Types.hs
+++ b/src/Ganeti/THH/Types.hs
@@ -123,4 +123,11 @@ curryN n = do
f <- newName "f"
ps <- replicateM n (newName "x")
return $ LamE (VarP f : map VarP ps)
- (AppE (VarE f) (TupE $ map VarE ps))
+ (AppE (VarE f) (nonUnaryTupE $ map VarE ps))
+ where
+ nonUnaryTupE :: [Exp] -> Exp
+ nonUnaryTupE es = TupE $
+#if MIN_VERSION_template_haskell(2,16,0)
+ map Just
+#endif
+ es

View file

@ -1,24 +0,0 @@
Adjust documentation for Sphinx 4.0.
Discussed upstream at <https://github.com/ganeti/ganeti/pull/1615>.
diff --git a/doc/index.rst b/doc/index.rst
--- a/doc/index.rst
+++ b/doc/index.rst
@@ -119,7 +119,6 @@ Draft designs
design-hotplug.rst
design-internal-shutdown.rst
design-kvmd.rst
- design-location.rst
design-linuxha.rst
design-location.rst
design-lu-generated-jobs.rst
diff --git a/lib/build/shell_example_lexer.py b/lib/build/shell_example_lexer.py
--- a/lib/build/shell_example_lexer.py
+++ b/lib/build/shell_example_lexer.py
@@ -79,4 +79,4 @@ class ShellExampleLexer(RegexLexer):
def setup(app):
- app.add_lexer("shell-example", ShellExampleLexer())
+ app.add_lexer("shell-example", ShellExampleLexer)

View file

@ -547,19 +547,17 @@ (define-public libx86emu
(define-public ganeti
(package
(name "ganeti")
(version "3.0.1")
(version "3.0.2")
(source (origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/ganeti/ganeti")
(commit (string-append "v" version))))
(sha256
(base32 "1i7gx0sdx9316fnldbv738s0ihym1370nhc1chk0biandkl8vvq0"))
(base32 "1xw7rm0k411aj0a4hrxz9drn7827bihp6bwizbapfx8k4c3125k4"))
(file-name (git-file-name name version))
(patches (search-patches "ganeti-shepherd-support.patch"
"ganeti-shepherd-master-failover.patch"
"ganeti-sphinx-compat.patch"
"ganeti-haskell-compat.patch"
"ganeti-haskell-pythondir.patch"
"ganeti-pyyaml-compat.patch"
"ganeti-disable-version-symlinks.patch"))))
@ -612,20 +610,6 @@ (define-public ganeti
,(system->qemu-target (%current-system))))
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-version-constraints
(lambda _
;; Loosen version constraints for compatibility with Stackage 18.10.
(substitute* "cabal/ganeti.template.cabal"
(("(.*base64-bytestring.*) < 1\\.1" _ match)
(string-append match " < 1.2"))
(("(.*QuickCheck.*) < 2\\.14" _ match)
(string-append match " < 2.15")))))
(add-after 'unpack 'pyparsing-compat
(lambda _
;; Adjust for Pyparsing 3.0. Remove for Ganeti 3.0.2+.
(substitute* "lib/qlang.py"
(("operatorPrecedence")
"infixNotation"))))
(add-after 'unpack 'create-vcs-version
(lambda _
;; If we are building from a git checkout, we need to create a
@ -717,6 +701,7 @@ (define-public ganeti
(("test/py/ganeti\\.asyncnotifier_unittest\\.py") "")
(("test/py/ganeti\\.backend_unittest\\.py") "")
(("test/py/ganeti\\.daemon_unittest\\.py") "")
(("test/py/ganeti\\.hypervisor\\.hv_kvm_unittest\\.py") "")
(("test/py/ganeti\\.tools\\.ensure_dirs_unittest\\.py") "")
(("test/py/ganeti\\.utils\\.io_unittest-runasroot\\.py") "")
;; Disable the bash_completion test, as it requires the full