gnu: nautilus: Fix build with libportal-0.5.
* gnu/packages/patches/nautilus-add-libportal-gtk3.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/gnome.scm (nautilus)[source]: Use it.
This commit is contained in:
parent
ea11be50e9
commit
a9678953ea
3 changed files with 68 additions and 1 deletions
|
@ -1507,6 +1507,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/musl-cross-locale.patch \
|
||||
%D%/packages/patches/mutt-store-references.patch \
|
||||
%D%/packages/patches/m4-gnulib-libio.patch \
|
||||
%D%/packages/patches/nautilus-add-libportal-gtk3.patch \
|
||||
%D%/packages/patches/ncompress-fix-softlinks.patch \
|
||||
%D%/packages/patches/netcdf-date-time.patch \
|
||||
%D%/packages/patches/netpbm-CVE-2017-2586.patch \
|
||||
|
|
|
@ -66,6 +66,7 @@
|
|||
;;; Copyright © 2021 Josselin Poiret <josselin.poiret@protonmail.ch>
|
||||
;;; Copyright © 2021 Mathieu Othacehe <othacehe@gnu.org>
|
||||
;;; Copyright © 2022 Daniel Meißner <daniel.meissner-i4k@ruhr-uni-bochum.de>
|
||||
;;; Copyright © 2022 Pierre Langlois <pierre.langlois@gmx.com>
|
||||
;;;
|
||||
;;; This file is part of GNU Guix.
|
||||
;;;
|
||||
|
@ -9095,7 +9096,11 @@ (define-public nautilus
|
|||
name "-" version ".tar.xz"))
|
||||
(sha256
|
||||
(base32
|
||||
"1rd1a0wjh2sc7mzw6m61rryvgxpi2lin4xj0x9khqw04q6nl3fgr"))))
|
||||
"1rd1a0wjh2sc7mzw6m61rryvgxpi2lin4xj0x9khqw04q6nl3fgr"))
|
||||
(patches
|
||||
;; This patch is already upstream and can be removed next
|
||||
;; release.
|
||||
(search-patches "nautilus-add-libportal-gtk3.patch"))))
|
||||
(build-system meson-build-system)
|
||||
(arguments
|
||||
`(#:glib-or-gtk? #t
|
||||
|
|
61
gnu/packages/patches/nautilus-add-libportal-gtk3.patch
Normal file
61
gnu/packages/patches/nautilus-add-libportal-gtk3.patch
Normal file
|
@ -0,0 +1,61 @@
|
|||
From 55cfd66ccca391fc144f5863ff6bfc1f3b137e2d Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Ant=C3=B3nio=20Fernandes?= <antoniojpfernandes@gmail.com>
|
||||
Date: Tue, 21 Dec 2021 17:42:27 +0000
|
||||
Subject: [PATCH] general: Add libportal-gtk3 dependency
|
||||
|
||||
The portal-gtk3.h header has been moved into a separate library which
|
||||
binds gtk3 explicitly.
|
||||
|
||||
https://github.com/flatpak/libportal/pull/53
|
||||
---
|
||||
build-aux/flatpak/org.gnome.Nautilus.json | 5 +++-- ;; Changes removed in Guix
|
||||
build-aux/flatpak/org.gnome.Nautilus.yml | 3 ++- ;; Changes removed in Guix
|
||||
meson.build | 4 +++-
|
||||
src/meson.build | 1 +
|
||||
src/nautilus-files-view.c | 2 +-
|
||||
5 files changed, 10 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/meson.build b/meson.build
|
||||
index 927216636..4626fa0bb 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -122,8 +122,10 @@ gnome_desktop = dependency('gnome-desktop-3.0', version: '>= 3.0.0')
|
||||
gtk = dependency('gtk+-3.0', version: '>= 3.22.27')
|
||||
libhandy = dependency('libhandy-1', version: '>= 1.1.90')
|
||||
libportal = []
|
||||
+libportal_gtk3 = []
|
||||
if get_option('libportal')
|
||||
- libportal = dependency('libportal', version: '>= 0.3')
|
||||
+ libportal = dependency('libportal', version: '>= 0.5')
|
||||
+ libportal_gtk3 = dependency('libportal-gtk3', version: '>= 0.5')
|
||||
endif
|
||||
selinux = []
|
||||
if get_option('selinux')
|
||||
diff --git a/src/meson.build b/src/meson.build
|
||||
index 682d6f3a3..d7fb76d53 100644
|
||||
--- a/src/meson.build
|
||||
+++ b/src/meson.build
|
||||
@@ -285,6 +285,7 @@ nautilus_deps = [
|
||||
libgd_dep,
|
||||
libhandy,
|
||||
libportal,
|
||||
+ libportal_gtk3,
|
||||
nautilus_extension,
|
||||
selinux,
|
||||
tracker_sparql,
|
||||
diff --git a/src/nautilus-files-view.c b/src/nautilus-files-view.c
|
||||
index dfb7fb26c..a24005a11 100644
|
||||
--- a/src/nautilus-files-view.c
|
||||
+++ b/src/nautilus-files-view.c
|
||||
@@ -93,7 +93,7 @@
|
||||
|
||||
#ifdef HAVE_LIBPORTAL
|
||||
#include <libportal/portal.h>
|
||||
-#include <libportal/portal-gtk3.h>
|
||||
+#include <libportal-gtk3/portal-gtk3.h>
|
||||
#endif
|
||||
|
||||
/* Minimum starting update inverval */
|
||||
--
|
||||
GitLab
|
||||
|
Loading…
Reference in a new issue