gnu: glib: Disable failing test.

* gnu/packages/glib.scm (glib)[source]: Add patch.
[arguments]: Remove custom 'increase-test-timeout phase.
* gnu/packages/patches/glib-skip-failing-test.patch: New file.
* gnu/local.mk (dist_patch_DATA): Register it.
This commit is contained in:
Efraim Flashner 2021-04-20 16:27:44 +03:00
parent 7fd5175693
commit a24562af52
No known key found for this signature in database
GPG Key ID: 41AAE7DCCA3D8351
3 changed files with 31 additions and 13 deletions

View File

@ -1083,6 +1083,7 @@ dist_patch_DATA = \
%D%/packages/patches/ghostscript-no-header-creationdate.patch \
%D%/packages/patches/gimp-make-gegl-introspect-optional.patch \
%D%/packages/patches/glib-appinfo-watch.patch \
%D%/packages/patches/glib-skip-failing-test.patch \
%D%/packages/patches/glibc-CVE-2018-11236.patch \
%D%/packages/patches/glibc-CVE-2018-11237.patch \
%D%/packages/patches/glibc-CVE-2019-7309.patch \

View File

@ -3,7 +3,7 @@
;;; Copyright © 2013, 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2014, 2015, 2016, 2017, 2018, 2021 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016, 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Lukas Gradl <lgradl@openmailbox.org>
;;; Copyright © 2017, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017 Petter <petter@mykolab.ch>
@ -187,7 +187,8 @@ shared NFS home directories.")
(sha256
(base32 "1sh3h6b734cxhdd1qlzvhxq6rc7k73dsisap5y3s419s9xc4ywv7"))
(patches
(search-patches "glib-appinfo-watch.patch"))
(search-patches "glib-appinfo-watch.patch"
"glib-skip-failing-test.patch"))
(modules '((guix build utils)))
(snippet
'(begin
@ -203,17 +204,6 @@ shared NFS home directories.")
#:configure-flags '("-Dman=true")
#:phases
(modify-phases %standard-phases
;; TODO: Remove the conditional in the next core-updates cycle.
;; Needed to build glib on slower ARM nodes.
,@(if (string-prefix? "arm" (%current-system))
`((add-after 'unpack 'increase-test-timeout
(lambda _
(substitute* "meson.build"
(("test_timeout = 60")
"test_timeout = 90")
(("test_timeout_slow = 120")
"test_timeout_slow = 180")))))
'())
(add-after 'unpack 'disable-failing-tests
(lambda _
(with-directory-excursion "glib/tests"

View File

@ -0,0 +1,27 @@
This test timed out on powerpc-linux even after extending the
test_timeout_slow to 1800 seconds. Previously we tried to work around
this test by extending test_timeout_slow by 1.5 its previous value.
---
gio/tests/meson.build | 4 ----
1 file changed, 4 deletions(-)
diff --git a/gio/tests/meson.build b/gio/tests/meson.build
index a926ae0..4fdbe7a 100644
--- a/gio/tests/meson.build
+++ b/gio/tests/meson.build
@@ -317,10 +317,6 @@ if host_machine.system() != 'windows'
'extra_sources' : [extra_sources, gdbus_test_codegen_generated, gdbus_test_codegen_generated_interface_info],
'c_args' : ['-DGLIB_VERSION_MIN_REQUIRED=GLIB_VERSION_2_32'],
},
- 'gdbus-threading' : {
- 'extra_sources' : extra_sources,
- 'suite' : ['slow'],
- },
'gmenumodel' : {
'extra_sources' : extra_sources,
'suite' : ['slow'],
--
2.31.1