gnu: fontconfig: Build fix for the Hurd.

* gnu/packages/patches/fontconfig-hurd-path-max.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/fontutils.scm (fontconfig): Use it.
This commit is contained in:
Jan Nieuwenhuizen 2020-03-08 20:07:24 -04:00
parent 7baa8c7898
commit 9dd9e8fabf
No known key found for this signature in database
GPG key ID: F3C1A0D9C1D65273
3 changed files with 19 additions and 0 deletions

View file

@ -886,6 +886,7 @@ dist_patch_DATA = \
%D%/packages/patches/foobillard++-pkg-config.patch \
%D%/packages/patches/foomatic-filters-CVE-2015-8327.patch \
%D%/packages/patches/foomatic-filters-CVE-2015-8560.patch \
%D%/packages/patches/fontconfig-hurd-path-max.patch \
%D%/packages/patches/freeimage-unbundle.patch \
%D%/packages/patches/fuse-overlapping-headers.patch \
%D%/packages/patches/gawk-shell.patch \

View file

@ -296,6 +296,7 @@ (define-public fontconfig
(uri (string-append
"https://www.freedesktop.org/software/fontconfig/release/fontconfig-"
version ".tar.bz2"))
(patches (search-patches "fontconfig-hurd-path-max.patch"))
(sha256 (base32
"0hb700a68kk0ip51wdlnjjc682kvlrmb6q920mzajykdk0mdsmgn"))))
(build-system gnu-build-system)

View file

@ -0,0 +1,17 @@
Avoid usage of PATH_MAX.
Taken from https://salsa.debian.org/freedesktop-team/fontconfig/-/blob/master/debian/patches/path_max.patch
Index: fontconfig-2.13.1/src/fccfg.c
===================================================================
--- fontconfig-2.13.1.orig/src/fccfg.c
+++ fontconfig-2.13.1/src/fccfg.c
@@ -2231,7 +2231,7 @@ FcConfigRealFilename (FcConfig *config,
if (n)
{
- FcChar8 buf[PATH_MAX];
+ FcChar8 buf[FC_PATH_MAX];
ssize_t len;
if (sysroot)