gnu: scilab: Update to 2024.0.0.

* gnu/packages/maths.scm (scilab): Update to 2024.0.0.  Remove patch.
[native-inputs]: Switch to AUTOCONF-2.71.
[inputs]: Switch to HDF5-1.10; add LIBARCHIVE.
[arguments]: Add ‘fix-linking’ phase.

Change-Id: Ie1af4dc620cee644388f6b8acf88ea50c4148b65
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
This commit is contained in:
Nicolas Graves 2023-11-06 00:51:49 +01:00 committed by Ludovic Courtès
parent 4c4da25dbf
commit 9d33830fd1
No known key found for this signature in database
GPG key ID: 090B11993D9AEBB5
2 changed files with 11 additions and 76 deletions

View file

@ -104,6 +104,7 @@ (define-module (gnu packages maths)
#:use-module (gnu packages algebra)
#:use-module (gnu packages audio)
#:use-module (gnu packages autotools)
#:use-module (gnu packages backup)
#:use-module (gnu packages base)
#:use-module (gnu packages bash)
#:use-module (gnu packages bison)
@ -9530,7 +9531,7 @@ (define-public optizelle
(define-public scilab
(package
(name "scilab")
(version "2023.1.0")
(version "2024.0.0")
(source
(origin
(method git-fetch)
@ -9540,10 +9541,9 @@ (define-public scilab
(file-name (git-file-name name version))
(sha256
(base32
"0hbqsnc67b4f8zc690kl79bwhjaasykjlmqbln8iymnjcn3l5ypd"))
"08nyfli3x7gd396ffd1a8zn9fj3gm6a8yw0ggm547c09sp2rgvl7"))
(modules '((guix build utils)
(ice-9 ftw)))
(patches (search-patches "scilab-hdf5-1.8-api.patch"))
(snippet
#~(begin
;; Delete everything except for scilab itself:
@ -9598,7 +9598,7 @@ (define-public scilab
"modules/ast/src/cpp/parse/parsescilab.cpp"))))))
(build-system gnu-build-system)
(native-inputs
(list autoconf
(list autoconf-2.71
autoconf-archive
automake
bison
@ -9615,8 +9615,9 @@ (define-public scilab
curl
fftw
gettext-minimal
hdf5-1.14
hdf5-1.10
lapack
libarchive
libx11
libxml2
matio
@ -9661,6 +9662,11 @@ (define-public scilab
"modules/scicos/src/translator/makefile.mak"
"modules/scicos/src/modelica_compiler/makefile.mak")
(("nums\\.cmx?a") ""))))
(add-after 'unpack 'fix-linking
(lambda _
(substitute* "modules/Makefile.am"
(("libscilab_cli_la_LDFLAGS = .*\\)" all)
(string-append all " -lcurl")))))
(add-after 'unpack 'restrain-to-scilab-cli
(lambda _
;; Install only scilab-cli.desktop

View file

@ -1,71 +0,0 @@
This patch fixes the compilation with hdf5 version >= 1.10. Adapted from
https://aur.archlinux.org/cgit/aur.git/plain/hdf5_18_api.patch?h=scilab-git.
diff -ur a/scilab/modules/hdf5/includes/HDF5Objects.h b/scilab/modules/hdf5/includes/HDF5Objects.h
--- a/scilab/modules/hdf5/includes/HDF5Objects.h
+++ b/scilab/modules/hdf5/includes/HDF5Objects.h
@@ -16,14 +16,12 @@
#ifndef __HDF5OBJECTS_H__
#define __HDF5OBJECTS_H__
-#define H5_NO_DEPRECATED_SYMBOLS
#undef H5_USE_16_API
+#define H5_USE_18_API
-#define H5Eset_auto_vers 2
#include <hdf5.h>
#include <hdf5_hl.h>
-#undef H5_NO_DEPRECATED_SYMBOLS
//#define __HDF5OBJECTS_DEBUG__
//#define __HDF5ERROR_PRINT__
diff -ur a/scilab/modules/hdf5/Makefile.am b/scilab/modules/hdf5/Makefile.am
--- a/scilab/modules/hdf5/Makefile.am
+++ b/scilab/modules/hdf5/Makefile.am
@@ -104,8 +104,7 @@
-DH5Gopen_vers=2 \
-DH5Tget_array_dims_vers=2 \
-DH5Acreate_vers=2 \
- -DH5Rdereference_vers=2 \
- -DNO_DEPRECATED_SYMBOLS
+ -DH5Rdereference_vers=2
libscihdf5_la_CPPFLAGS = \
diff -ur a/scilab/modules/hdf5/sci_gateway/cpp/sci_hdf5_listvar_v3.cpp b/scilab/modules/hdf5/sci_gateway/cpp/sci_hdf5_listvar_v3.cpp
--- a/scilab/modules/hdf5/sci_gateway/cpp/sci_hdf5_listvar_v3.cpp
+++ b/scilab/modules/hdf5/sci_gateway/cpp/sci_hdf5_listvar_v3.cpp
@@ -13,6 +13,8 @@
*
*/
+#define H5_USE_18_API
+
#include <vector>
#include "function.hxx"
#include "string.hxx"
diff -ur a/scilab/modules/hdf5/src/c/h5_readDataFromFile.c b/scilab/modules/hdf5/src/c/h5_readDataFromFile.c
--- a/scilab/modules/hdf5/src/c/h5_readDataFromFile.c
+++ b/scilab/modules/hdf5/src/c/h5_readDataFromFile.c
@@ -13,7 +13,7 @@
*
*/
-#define H5_NO_DEPRECATED_SYMBOLS
+#define H5_USE_18_API
#ifndef _MSC_VER
#include <sys/time.h>
diff -ur a/scilab/modules/hdf5/src/c/h5_readDataFromFile_v1.c b/scilab/modules/hdf5/src/c/h5_readDataFromFile_v1.c
--- a/scilab/modules/hdf5/src/c/h5_readDataFromFile_v1.c
+++ b/scilab/modules/hdf5/src/c/h5_readDataFromFile_v1.c
@@ -13,7 +13,7 @@
*
*/
-#define H5_NO_DEPRECATED_SYMBOLS
+#define H5_USE_18_API
#ifndef _MSC_VER
#include <sys/time.h>