gnu: feh: Adapt tests for imlib2 1.6.
* gnu/packages/patches/feh-fix-tests-for-imlib2-1.6.patch: New file. * gnu/packages/image-viewers.scm (feh)[source]: Use it. * gnu/local.mk (dist_patch_DATA): Add it. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
This commit is contained in:
parent
ba5ef9997b
commit
9943d238e9
3 changed files with 56 additions and 1 deletions
|
@ -826,6 +826,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/fbreader-curl-7.62.patch \
|
||||
%D%/packages/patches/fcgi-2.4.0-gcc44-fixes.patch \
|
||||
%D%/packages/patches/fcgi-2.4.0-poll.patch \
|
||||
%D%/packages/patches/feh-fix-tests-for-imlib2-1.6.patch \
|
||||
%D%/packages/patches/fifo-map-fix-flags-for-gcc.patch \
|
||||
%D%/packages/patches/fifo-map-remove-catch.hpp.patch \
|
||||
%D%/packages/patches/file-CVE-2018-10360.patch \
|
||||
|
|
|
@ -11,6 +11,7 @@
|
|||
;;; Copyright © 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
|
||||
;;; Copyright © 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
|
||||
;;; Copyright © 2019 Guy Fleury Iteriteka <hoonandon@gmail.com>
|
||||
;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
|
||||
;;;
|
||||
;;; This file is part of GNU Guix.
|
||||
;;;
|
||||
|
@ -72,7 +73,9 @@ (define-public feh
|
|||
name "-" version ".tar.bz2"))
|
||||
(sha256
|
||||
(base32
|
||||
"070axq8jpibcabmjfv4fmjmpk3k349vzvh4qhsi4n62bkcwl35wg"))))
|
||||
"070axq8jpibcabmjfv4fmjmpk3k349vzvh4qhsi4n62bkcwl35wg"))
|
||||
(patches
|
||||
(search-patches "feh-fix-tests-for-imlib2-1.6.patch"))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
'(#:phases (modify-phases %standard-phases (delete 'configure))
|
||||
|
|
51
gnu/packages/patches/feh-fix-tests-for-imlib2-1.6.patch
Normal file
51
gnu/packages/patches/feh-fix-tests-for-imlib2-1.6.patch
Normal file
|
@ -0,0 +1,51 @@
|
|||
commit 8048fb542d0c36f868760ba1590fbe14a3a85df7
|
||||
Author: Pierre Langlois <pierre.langlois@gmx.com>
|
||||
Date: Wed Nov 27 10:42:05 2019 +0000
|
||||
|
||||
Adapt tests for imlib2 1.6
|
||||
|
||||
Reported upstream on https://github.com/derf/feh/issues/497
|
||||
|
||||
diff --git a/test/list/custom b/test/list/custom
|
||||
index dbe2074..40ac557 100644
|
||||
--- a/test/list/custom
|
||||
+++ b/test/list/custom
|
||||
@@ -1,4 +1,4 @@
|
||||
test/ok/gif; 16; 4; list; gif; 256; 953; gif; 1; 16
|
||||
-test/ok/jpg; 16; 4; list; jpg; 256; 354; jpeg; 2; 16
|
||||
+test/ok/jpg; 16; 4; list; jpg; 256; 354; jpg; 2; 16
|
||||
test/ok/png; 16; 4; list; png; 256; 403; png; 3; 16
|
||||
test/ok/pnm; 16; 4; list; pnm; 256; 269; pnm; 4; 16
|
||||
diff --git a/test/list/default b/test/list/default
|
||||
index bc0ef52..e480db3 100644
|
||||
--- a/test/list/default
|
||||
+++ b/test/list/default
|
||||
@@ -1,5 +1,5 @@
|
||||
NUM FORMAT WIDTH HEIGHT PIXELS SIZE ALPHA FILENAME
|
||||
1 gif 16 16 256 953 - test/ok/gif
|
||||
-2 jpeg 16 16 256 354 - test/ok/jpg
|
||||
+2 jpg 16 16 256 354 - test/ok/jpg
|
||||
3 png 16 16 256 403 X test/ok/png
|
||||
4 pnm 16 16 256 269 - test/ok/pnm
|
||||
diff --git a/test/list/format_reverse b/test/list/format_reverse
|
||||
index 9216184..3301f78 100644
|
||||
--- a/test/list/format_reverse
|
||||
+++ b/test/list/format_reverse
|
||||
@@ -1,5 +1,5 @@
|
||||
NUM FORMAT WIDTH HEIGHT PIXELS SIZE ALPHA FILENAME
|
||||
1 pnm 16 16 256 269 - test/ok/pnm
|
||||
2 png 16 16 256 403 X test/ok/png
|
||||
-3 jpeg 16 16 256 354 - test/ok/jpg
|
||||
+3 jpg 16 16 256 354 - test/ok/jpg
|
||||
4 gif 16 16 256 953 - test/ok/gif
|
||||
diff --git a/test/list/size b/test/list/size
|
||||
index cad60b0..7716239 100644
|
||||
--- a/test/list/size
|
||||
+++ b/test/list/size
|
||||
@@ -1,5 +1,5 @@
|
||||
NUM FORMAT WIDTH HEIGHT PIXELS SIZE ALPHA FILENAME
|
||||
1 pnm 16 16 256 269 - test/ok/pnm
|
||||
-2 jpeg 16 16 256 354 - test/ok/jpg
|
||||
+2 jpg 16 16 256 354 - test/ok/jpg
|
||||
3 png 16 16 256 403 X test/ok/png
|
||||
4 gif 16 16 256 953 - test/ok/gif
|
Loading…
Reference in a new issue