gnu: mesa-opencl: Remove reference to patch.

Fixes <https://bugs.gnu.org/63456>.

* gnu/packages/patches/mesa-opencl-all-targets.patch: Remove file.
* gnu/local.mk (dist_patch_DATA): Remove it.
* gnu/packages/gl.scm (mesa-opencl)[source]: Remove patch application.

Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
This commit is contained in:
Andy Tai 2023-05-11 23:50:14 -07:00 committed by Guillaume Le Vaillant
parent 56f52639bb
commit 930e6e3e7a
No known key found for this signature in database
GPG key ID: 6BE8208ADF21FE3F
3 changed files with 1 additions and 29 deletions

View file

@ -1562,7 +1562,6 @@ dist_patch_DATA = \
%D%/packages/patches/memtest86+-build-reproducibly.patch \
%D%/packages/patches/mercurial-hg-extension-path.patch \
%D%/packages/patches/mercurial-openssl-compat.patch \
%D%/packages/patches/mesa-opencl-all-targets.patch \
%D%/packages/patches/mhash-keygen-test-segfault.patch \
%D%/packages/patches/mia-fix-boost-headers.patch \
%D%/packages/patches/mia-vtk9.patch \

View file

@ -530,9 +530,7 @@ (define-public mesa-opencl
(package/inherit mesa
(name "mesa-opencl")
(source (origin
(inherit (package-source mesa))
(patches (cons (search-patch "mesa-opencl-all-targets.patch")
(origin-patches (package-source mesa))))))
(inherit (package-source mesa))))
(arguments
(substitute-keyword-arguments (package-arguments mesa)
((#:configure-flags flags)

View file

@ -1,25 +0,0 @@
This patch restores LLVM targets needed for OpenCL, *reverting* this
upstream commit:
From 80817b6e344258ac9b955f824ebf9019a0fc1610 Mon Sep 17 00:00:00 2001
From: Jesse Natalie <jenatali@microsoft.com>
Date: Wed, 18 Nov 2020 18:30:30 -0800
Subject: [PATCH] meson: Adjust Clover's required LLVM modules
diff --git a/meson.build b/meson.build
index 6d1607c35a3..f828eb80faa 100644
--- b/meson.build
+++ a/meson.build
@@ -1479,10 +1479,9 @@
endif
if with_gallium_opencl
llvm_modules += [
- 'linker', 'coverage', 'instrumentation', 'ipo', 'irreader',
- 'lto', 'option', 'objcarcopts', 'profiledata'
+ 'all-targets', 'linker', 'coverage', 'instrumentation', 'ipo', 'irreader',
+ 'lto', 'option', 'objcarcopts', 'profiledata',
]
- llvm_optional_modules += ['frontendopenmp']
endif
if with_microsoft_clc
llvm_modules += ['target', 'linker', 'irreader', 'option', 'libdriver']