gnu: julia-tracker: Update to 0.2.22.

* gnu/packages/julia-xyz.scm (julia-tracker): Update to 0.2.22.
[source]: Remove patch.
[propagated-inputs]: Add julia-functors, julia-logexpfunctions,
julia-optimisers.
* gnu/packages/patches/julia-tracker-16-compat.patch: Remove file.
* gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
Efraim Flashner 2022-12-13 21:18:31 +02:00
parent ca8be377a2
commit 8bc31f951b
No known key found for this signature in database
GPG key ID: 41AAE7DCCA3D8351
3 changed files with 5 additions and 44 deletions

View file

@ -1378,7 +1378,6 @@ dist_patch_DATA = \
%D%/packages/patches/json-c-0.12-CVE-2020-12762.patch \
%D%/packages/patches/jsoncpp-pkg-config-version.patch \
%D%/packages/patches/julia-SOURCE_DATE_EPOCH-mtime.patch \
%D%/packages/patches/julia-tracker-16-compat.patch \
%D%/packages/patches/libffi-3.3-powerpc-fixes.patch \
%D%/packages/patches/libffi-float128-powerpc64le.patch \
%D%/packages/patches/libgeotiff-fix-tests-with-proj-9.1.1.patch \

View file

@ -5784,7 +5784,7 @@ (define-public julia-testimages
(define-public julia-tracker
(package
(name "julia-tracker")
(version "0.2.12")
(version "0.2.22")
(source
(origin
(method git-fetch)
@ -5793,16 +5793,18 @@ (define-public julia-tracker
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32 "1s4mdywbp7nli7z985fqaj1rs4i6d92b1jx3lhg0qhk1s5wc0v8j"))
(patches (search-patches "julia-tracker-16-compat.patch"))))
(base32 "0sxncn999dc5j15y0h3cw28x41pv5qjaw64drhy1y4rn3na48504"))))
(build-system julia-build-system)
(propagated-inputs
(list julia-adapt
julia-diffrules
julia-forwarddiff
julia-functors
julia-logexpfunctions
julia-macrotools
julia-nanmath
julia-nnlib
julia-optimisers
julia-requires
julia-specialfunctions))
(native-inputs

View file

@ -1,40 +0,0 @@
https://github.com/FluxML/Tracker.jl/commit/f6550ba38a9ea5802e2de4fa9c939929ba711f0d.patch
from an upstream pull request
https://github.com/FluxML/Tracker.jl/pull/94
From f6550ba38a9ea5802e2de4fa9c939929ba711f0d Mon Sep 17 00:00:00 2001
From: Michael Abbott <me@escbook>
Date: Wed, 3 Feb 2021 22:58:33 +0100
Subject: [PATCH] two fixes for 1.6
---
src/lib/array.jl | 2 +-
src/lib/real.jl | 1 +
2 files changed, 2 insertions(+), 1 deletion(-)
diff --git a/src/lib/array.jl b/src/lib/array.jl
index 92f2b39..f8cbbac 100644
--- a/src/lib/array.jl
+++ b/src/lib/array.jl
@@ -298,7 +298,7 @@ Base.reverse(xs::TrackedArray; dims) = track(reverse, xs, dims = dims)
@grad reverse(xs; dims) = reverse(data(xs), dims = dims), Δ -> (reverse(Δ, dims = dims), nothing)
Base.reverse(xs::TrackedVector) = track(reverse, xs)
@grad reverse(xs::TrackedVector) = reverse(data(xs)), Δ -> (reverse(Δ),)
-Base.reverse(xs::TrackedVector, start, stop) = track(reverse, xs, start, stop)
+Base.reverse(xs::TrackedVector, start::Integer, stop::Integer) = track(reverse, xs, start, stop)
@grad reverse(xs, start, stop) = reverse(data(xs), start, stop), Δ -> (reverse(Δ, start, stop), nothing, nothing)
function _kron(mat1::AbstractMatrix,mat2::AbstractMatrix)
diff --git a/src/lib/real.jl b/src/lib/real.jl
index 737afd8..e1975ac 100644
--- a/src/lib/real.jl
+++ b/src/lib/real.jl
@@ -55,6 +55,7 @@ for f in :[isinf, isnan, isfinite].args
end
Printf.fix_dec(x::TrackedReal, n::Int, a...) = Printf.fix_dec(data(x), n, a...)
+Printf.tofloat(x::TrackedReal) = Printf.tofloat(data(x))
Base.float(x::TrackedReal) = x