gnu: Add rust-ndarray-0.14.
* gnu/packages/crates-io.scm (rust-ndarray-0.14): New variable. * gnu/packages/patches/rust-ndarray-0.14-remove-blas-src.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it.
This commit is contained in:
parent
73e2312802
commit
8b54123a9d
3 changed files with 56 additions and 0 deletions
|
@ -1775,6 +1775,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/i3status-rust-enable-unstable-features.patch \
|
||||
%D%/packages/patches/rust-ndarray-remove-blas-src-dep.patch \
|
||||
%D%/packages/patches/rust-ndarray-0.13-remove-blas-src.patch \
|
||||
%D%/packages/patches/rust-ndarray-0.14-remove-blas-src.patch \
|
||||
%D%/packages/patches/rust-nettle-disable-vendor.patch \
|
||||
%D%/packages/patches/rust-nettle-sys-disable-vendor.patch \
|
||||
%D%/packages/patches/rust-openssl-sys-no-vendor.patch \
|
||||
|
|
|
@ -36289,6 +36289,36 @@ (define-public rust-ndarray-0.15
|
|||
(license (list license:asl2.0
|
||||
license:expat))))
|
||||
|
||||
(define-public rust-ndarray-0.14
|
||||
(package
|
||||
(inherit rust-ndarray-0.15)
|
||||
(name "rust-ndarray")
|
||||
(version "0.14.0")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
(uri (crate-uri "ndarray" version))
|
||||
(file-name (string-append name "-" version ".tar.gz"))
|
||||
(sha256
|
||||
(base32 "011wqzmrd9gpfcfvy1xfbskqfiahn96pmi2d0r9x34d682amq3bc"))
|
||||
(patches (search-patches "rust-ndarray-0.14-remove-blas-src.patch"))))
|
||||
(arguments
|
||||
`(#:cargo-inputs
|
||||
(("rust-approx" ,rust-approx-0.4)
|
||||
("rust-cblas-sys" ,rust-cblas-sys-0.1)
|
||||
("rust-matrixmultiply" ,rust-matrixmultiply-0.2)
|
||||
("rust-num-complex" ,rust-num-complex-0.3)
|
||||
("rust-num-integer" ,rust-num-integer-0.1)
|
||||
("rust-num-traits" ,rust-num-traits-0.2)
|
||||
("rust-rawpointer" ,rust-rawpointer-0.2)
|
||||
("rust-rayon" ,rust-rayon-1)
|
||||
("rust-serde" ,rust-serde-1))
|
||||
#:cargo-development-inputs
|
||||
(("rust-approx" ,rust-approx-0.4)
|
||||
("rust-defmac" ,rust-defmac-0.2)
|
||||
("rust-itertools" ,rust-itertools-0.9)
|
||||
("rust-quickcheck" ,rust-quickcheck-0.9))))))
|
||||
|
||||
(define-public rust-ndarray-0.13
|
||||
(package
|
||||
(inherit rust-ndarray-0.15)
|
||||
|
|
25
gnu/packages/patches/rust-ndarray-0.14-remove-blas-src.patch
Normal file
25
gnu/packages/patches/rust-ndarray-0.14-remove-blas-src.patch
Normal file
|
@ -0,0 +1,25 @@
|
|||
diff --git a/Cargo.toml b/Cargo.toml
|
||||
index 57924f1..0c59727 100644
|
||||
--- a/Cargo.toml
|
||||
+++ b/Cargo.toml
|
||||
@@ -43,11 +43,6 @@ bench = false
|
||||
version = "0.4"
|
||||
optional = true
|
||||
|
||||
-[dependencies.blas-src]
|
||||
-version = "0.6.1"
|
||||
-optional = true
|
||||
-default-features = false
|
||||
-
|
||||
[dependencies.cblas-sys]
|
||||
version = "0.1.4"
|
||||
optional = true
|
||||
@@ -92,7 +87,7 @@ version = "0.9"
|
||||
default-features = false
|
||||
|
||||
[features]
|
||||
-blas = ["cblas-sys", "blas-src"]
|
||||
+blas = ["cblas-sys"]
|
||||
docs = ["approx", "serde", "rayon"]
|
||||
serde-1 = ["serde"]
|
||||
test = ["test-blas-openblas-sys"]
|
Loading…
Reference in a new issue