gnu: LLVM, Clang: Update to 12.0.1.

* gnu/packages/patches/clang-12-tools-extra-directory.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/llvm.scm (llvm-12, clang-runtime-12): Update to 12.0.1.
(clang-12): Likewise.  Remove obsolete patch.
This commit is contained in:
Marius Bakke 2021-09-22 22:22:43 +02:00
parent 06f47e0256
commit 855e34d44f
No known key found for this signature in database
GPG key ID: A2A06DF2A33A54FA
3 changed files with 5 additions and 24 deletions

View file

@ -920,7 +920,6 @@ dist_patch_DATA = \
%D%/packages/patches/clang-9.0-libc-search-path.patch \
%D%/packages/patches/clang-10.0-libc-search-path.patch \
%D%/packages/patches/clang-11.0-libc-search-path.patch \
%D%/packages/patches/clang-12-tools-extra-directory.patch \
%D%/packages/patches/clang-runtime-asan-build-fixes.patch \
%D%/packages/patches/clang-runtime-esan-build-fixes.patch \
%D%/packages/patches/clang-runtime-9-libsanitizer-mode-field.patch \

View file

@ -480,14 +480,14 @@ (define (make-clang-toolchain clang)
(define-public llvm-12
(package
(name "llvm")
(version "12.0.0")
(version "12.0.1")
(source
(origin
(method url-fetch)
(uri (llvm-uri "llvm" version))
(sha256
(base32
"0l4b79gwfvxild974aigcq1yigypjsk2j5p59syhl6ksd744gp29"))))
"1pzx9zrmd7r3481sbhwvkms68fwhffpp4mmz45dgrkjpyl2q96kx"))))
(build-system cmake-build-system)
(outputs '("out" "opt-viewer"))
(native-inputs
@ -542,22 +542,20 @@ (define-public llvm-12
(define-public clang-runtime-12
(clang-runtime-from-llvm
llvm-12
"0d444qihq9jhqnfv003cr704v363va72zl6qaw2algj1c85cva45"))
"1950rg294izdwkaasi7yjrmadc9mzdd5paf0q63jjcq2m3rdbj5l"))
(define-public clang-12
(clang-from-llvm llvm-12 clang-runtime-12
"1vd9rhhrd8ghdg111lac7w8by71y9l14yh5zxfijsm6lj4p4avp2"
"0px4gl27az6cdz6adds89qzdwb1cqpjsfvrldbz9qvpmphrj34bf"
#:patches '("clang-11.0-libc-search-path.patch")
#:tools-extra
(origin
(method url-fetch)
(uri (llvm-uri "clang-tools-extra"
(package-version llvm-12)))
(patches
(search-patches "clang-12-tools-extra-directory.patch"))
(sha256
(base32
"0p3dzr0qa7mar83y66xa5m5apynf6ia0lsdsq6axwnm64ysy0hdd")))))
"1r9a4fdz9ci58b5z2inwvm4z4cdp6scrivnaw05dggkxz7yrwrb5")))))
(define-public clang-toolchain-12
(make-clang-toolchain clang-12))

View file

@ -1,16 +0,0 @@
Help CMake locate the "tools-extra" directory.
Taken from <https://bugs.llvm.org/show_bug.cgi?id=49990#c3>.
diff --git a/clang-tools-extra/clangd/quality/CompletionModel.cmake b/clang-tools-extra/clangd/quality/CompletionModel.cmake
--- a/clangd/quality/CompletionModel.cmake
+++ b/clangd/quality/CompletionModel.cmake
@@ -5,7 +5,7 @@
# will define a C++ class called ${cpp_class} - which may be a
# namespace-qualified class name.
function(gen_decision_forest model filename cpp_class)
- set(model_compiler ${CMAKE_SOURCE_DIR}/../clang-tools-extra/clangd/quality/CompletionModelCodegen.py)
+ set(model_compiler ${CMAKE_CURRENT_LIST_DIR}/quality/CompletionModelCodegen.py)
set(output_dir ${CMAKE_CURRENT_BINARY_DIR})
set(header_file ${output_dir}/${filename}.h)