gnu: jami: Update to 20220825.0828.c10f01f.

* gnu/packages/jami.scm (jami): Update to 20220825.0828.c10f01f.
(%jami-version): Set to latest release.
(%jami-sources): Remove jami-fix-esc-bug.patch; add
jami-fix-crash-on-block-contact.patch.
* gnu/packages/patches/jami-fix-esc-bug.patch: Delete file.
* gnu/packages/patches/jami-fix-crash-on-block-contact.patch: New file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
This commit is contained in:
Maxim Cournoyer 2022-09-17 23:28:45 -04:00
parent 503cfd5421
commit 84369105d4
No known key found for this signature in database
GPG key ID: 1260E46482E63562
4 changed files with 39 additions and 31 deletions

View file

@ -1325,10 +1325,7 @@ dist_patch_DATA = \
%D%/packages/patches/irrlicht-link-against-needed-libs.patch \
%D%/packages/patches/isl-0.11.1-aarch64-support.patch \
%D%/packages/patches/itk-snap-alt-glibc-compat.patch \
%D%/packages/patches/jami-fix-esc-bug.patch \
%D%/packages/patches/json-c-0.13-CVE-2020-12762.patch \
%D%/packages/patches/json-c-0.12-CVE-2020-12762.patch \
%D%/packages/patches/jsoncpp-pkg-config-version.patch \
%D%/packages/patches/jami-fix-crash-on-block-contact.patch \
%D%/packages/patches/jamvm-1.5.1-aarch64-support.patch \
%D%/packages/patches/jamvm-1.5.1-armv7-support.patch \
%D%/packages/patches/jamvm-2.0.0-aarch64-support.patch \
@ -1350,6 +1347,9 @@ dist_patch_DATA = \
%D%/packages/patches/jfsutils-add-sysmacros.patch \
%D%/packages/patches/jfsutils-gcc-compat.patch \
%D%/packages/patches/jfsutils-include-systypes.patch \
%D%/packages/patches/json-c-0.13-CVE-2020-12762.patch \
%D%/packages/patches/json-c-0.12-CVE-2020-12762.patch \
%D%/packages/patches/jsoncpp-pkg-config-version.patch \
%D%/packages/patches/julia-SOURCE_DATE_EPOCH-mtime.patch \
%D%/packages/patches/julia-tracker-16-compat.patch \
%D%/packages/patches/julia-allow-parallel-build.patch \

View file

@ -66,7 +66,7 @@ (define-module (gnu packages jami)
#:use-module (guix packages)
#:use-module (guix utils))
(define %jami-version "20220726.1515.da8d1da")
(define %jami-version "20220825.0828.c10f01f")
(define %jami-sources
;; Return an origin object of the tarball release sources archive of the
@ -90,8 +90,8 @@ (define %jami-sources
"plugins"))))
(sha256
(base32
"1zx0i9aw8jsba3bjc5r4pkkybm8c0lyz420ciq89vsswd48gfdhg"))
(patches (search-patches "jami-fix-esc-bug.patch"))))
"1iv06jb66g206qxm75v7rc3mqvrml1028avflsj11chj8jh63j14"))
(patches (search-patches "jami-fix-crash-on-block-contact.patch"))))
;; Jami maintains a set of patches for some key dependencies (currently
;; pjproject and ffmpeg) of Jami that haven't yet been integrated upstream.

View file

@ -0,0 +1,32 @@
From 673dc5f525c9d478fc22f8ea0a50d9849a81f6c8 Mon Sep 17 00:00:00 2001
From: Kateryna Kostiuk <kateryna.kostiuk@savoirfairelinux.com>
Date: Fri, 2 Sep 2022 13:32:10 -0400
Subject: [PATCH] conversation: fix crash when block contact
This patch fixes crash that happened when block contact
for not active account.
GitLab: #758
Change-Id: I5347394a67cdffe0d95c9ee03aedf9d2618cec55
---
src/jamidht/jamiaccount.cpp | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/daemon/src/jamidht/jamiaccount.cpp b/daemon/src/jamidht/jamiaccount.cpp
index fe15eedb2..9d0a5ee68 100644
--- a/daemon/src/jamidht/jamiaccount.cpp
+++ b/daemon/src/jamidht/jamiaccount.cpp
@@ -1129,7 +1129,9 @@ JamiAccount::loadAccount(const std::string& archive_password,
if (auto convModule = shared->convModule())
convModule->removeContact(uri, banned);
// Remove current connections with contact
- shared->connectionManager_->closeConnectionsWith(uri);
+ if (shared->connectionManager_) {
+ shared->connectionManager_->closeConnectionsWith(uri);
+ }
// Update client.
emitSignal<DRing::ConfigurationSignal::ContactRemoved>(shared->getAccountID(),
uri,
--
2.37.3

View file

@ -1,24 +0,0 @@
This fixes the issue where pressing the ESC key would hide the Jami
GUI on systems lacking a notification tray.
From 47fd4c38ddd8bd350319ce9bb750ca496826e655 Mon Sep 17 00:00:00 2001
From: Sébastien Blin <sebastien.blin@savoirfairelinux.com>
Date: Fri, 29 Jul 2022 21:24:01 -0400
Subject: [PATCH] layoutmanager: fix popFullScreenItem
Change-Id: I79780d4ad570846e6f3c52734dd627bcd0e11327
---
diff --git a/src/app/LayoutManager.qml b/src/app/LayoutManager.qml
index 98516ce..87f13ac 100644
--- a/client-qt/src/app/LayoutManager.qml
+++ b/client-qt/src/app/LayoutManager.qml
@@ -176,7 +176,7 @@
// Only leave fullscreen mode if our window isn't in fullscreen
// mode already.
- if (priv.fullScreenItems.length === 0) {
+ if (priv.fullScreenItems.length === 0 && priv.windowedVisibility !== Window.Hidden) {
// Simply recall the last visibility state.
visibility = priv.windowedVisibility
}