gnu: rust-openssl-sys-0.9: Update to 0.9.93.

* gnu/packages/crates-io.scm (rust-openssl-sys-0.9): Update to 0.9.93.
[source]: Remove patch. Add snippet to remove dependencies on boringssl
and openssl source.
* gnu/packages/patches/rust-openssl-src-no-vendor.patch: Remove file.
* gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
Efraim Flashner 2023-10-02 10:34:30 +03:00
parent ad5e61ce9d
commit 7fcf7d94f2
No known key found for this signature in database
GPG key ID: 41AAE7DCCA3D8351
3 changed files with 13 additions and 39 deletions

View file

@ -1955,7 +1955,6 @@ dist_patch_DATA = \
%D%/packages/patches/rust-ndarray-0.13-remove-blas-src.patch \
%D%/packages/patches/rust-ndarray-0.14-remove-blas-src.patch \
%D%/packages/patches/rust-nettle-disable-vendor.patch \
%D%/packages/patches/rust-openssl-sys-no-vendor.patch \
%D%/packages/patches/rust-webbrowser-remove-unsupported-os.patch \
%D%/packages/patches/rust-wl-clipboard-rs-newer-wl.patch \
%D%/packages/patches/rw-igraph-0.10.patch \

View file

@ -44725,22 +44725,29 @@ (define-public rust-openssl-probe-0.1
(define-public rust-openssl-sys-0.9
(package
(name "rust-openssl-sys")
(version "0.9.87")
(version "0.9.93")
(source
(origin
(method url-fetch)
(uri (crate-uri "openssl-sys" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32 "0znc0q7a2gi2pmkscv0d6wzpfd64mgmy3w4lmrvrv05jcj9ga5wf"))
(patches (search-patches "rust-openssl-sys-no-vendor.patch"))))
(base32 "078vnn4s18kj8m5sd7b684frhjnxjcjc9z7s7h4871s7q2j5ckfv"))
(snippet
#~(begin
(use-modules (guix build utils))
;; Remove dependency on boringssl and vendor openssl source.
(substitute* "Cargo.toml.orig"
(("vendored = .*") "vendored = []\n")
((".*bssl.*") "")
((".*openssl-src.*") ""))
(copy-file "Cargo.toml.orig" "Cargo.toml")))))
(build-system cargo-build-system)
(arguments
`(#:cargo-inputs
(("rust-libc" ,rust-libc-0.2)
;; Build dependencies:
("rust-bindgen" ,rust-bindgen-0.64)
(("rust-bindgen" ,rust-bindgen-0.64)
("rust-cc" ,rust-cc-1)
("rust-libc" ,rust-libc-0.2)
("rust-pkg-config" ,rust-pkg-config-0.3)
("rust-vcpkg" ,rust-vcpkg-0.2))))
(native-inputs

View file

@ -1,32 +0,0 @@
--- openssl-sys-0.9.84/Cargo.toml.orig 2023-04-03 09:10:11.979197979 -0400
+++ openssl-sys-0.9.84/Cargo.toml 2023-04-03 12:07:30.285315609 -0400
@@ -31,10 +31,6 @@
[package.metadata.pkg-config]
openssl = "1.0.1"
-[dependencies.bssl-sys]
-version = "0.1.0"
-optional = true
-
[dependencies.libc]
version = "0.2"
@@ -46,16 +42,12 @@
[build-dependencies.cc]
version = "1.0"
-[build-dependencies.openssl-src]
-version = "111"
-optional = true
-
[build-dependencies.pkg-config]
version = "0.3.9"
[features]
-unstable_boringssl = ["bssl-sys"]
-vendored = ["openssl-src"]
+unstable_boringssl = []
+vendored = []
[target."cfg(target_env = \"msvc\")".build-dependencies.vcpkg]
version = "0.2.8"