gnu: libffi: Add unreleased patch to fix float128 on powerpc64le.

Fixes <https://bugs.gnu.org/45252>.

* gnu/packages/patches/libffi-float128-powerpc64le.patch: Import patch file
from <https://github.com/libffi/libffi/pull/561.patch>.
* gnu/packages/libffi.scm (libffi)[arguments]: Apply patch conditionally for
powerpc64le-* systems in a phase.
[inputs]: Add patch as input conditionally for powerpc64le-* systems.
* gnu/local.mk (dist_patch_DATA): Add patch file to build system.

Signed-off-by: Chris Marusich <cmmarusich@gmail.com>
This commit is contained in:
John Doe 2020-12-15 10:24:11 +01:00 committed by Chris Marusich
parent e8e9a7898e
commit 7eaa2f24ea
No known key found for this signature in database
GPG key ID: DD409A15D822469D
3 changed files with 80 additions and 5 deletions

View file

@ -1212,6 +1212,7 @@ dist_patch_DATA = \
%D%/packages/patches/julia-SOURCE_DATE_EPOCH-mtime.patch \
%D%/packages/patches/kdbusaddons-kinit-file-name.patch \
%D%/packages/patches/libffi-3.3-powerpc-fixes.patch \
%D%/packages/patches/libffi-float128-powerpc64le.patch \
%D%/packages/patches/libvirt-create-machine-cgroup.patch \
%D%/packages/patches/libziparchive-add-includes.patch \
%D%/packages/patches/localed-xorg-keyboard.patch \

View file

@ -7,6 +7,7 @@
;;; Copyright © 2017, 2019, 2020 Marius Bakke <marius@gnu.org>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2020 John Doe <dftxbs3e@free.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@ -57,7 +58,7 @@ (define-public libffi
;; compiler. See "ax_cc_maxopt.m4" and "ax_gcc_archflag.m4".
#:configure-flags '("--enable-portable-binary" "--without-gcc-arch")
;; TODO: Inline patch on next rebuild cycle.
;; TODO: Inline patches on next rebuild cycle.
,@(if (string-prefix? "powerpc-" (or (%current-target-system)
(%current-system)))
'(#:phases (modify-phases %standard-phases
@ -67,13 +68,28 @@ (define-public libffi
"powerpc-patch")))
(invoke "patch" "--batch" "-p1"
"-i" patch))))))
'())
,@(if (string-prefix? "powerpc64le-" (or (%current-target-system)
(%current-system)))
'(#:phases (modify-phases %standard-phases
(add-after 'unpack 'apply-patch2
(lambda* (#:key inputs #:allow-other-keys)
(let ((patch (assoc-ref inputs
"powerpc64le-patch")))
(invoke "patch" "--batch" "-p1"
"-i" patch))))))
'())))
(inputs
(if (string-prefix? "powerpc-" (or (%current-target-system)
(cond
((string-prefix? "powerpc-" (or (%current-target-system)
(%current-system)))
`(("powerpc-patch" ,@(search-patches
"libffi-3.3-powerpc-fixes.patch")))
'()))
`(("powerpc-patch" ,@(search-patches
"libffi-3.3-powerpc-fixes.patch"))))
((string-prefix? "powerpc64le-" (or (%current-target-system)
(%current-system)))
`(("powerpc64le-patch" ,@(search-patches
"libffi-float128-powerpc64le.patch"))))
(else '())))
(outputs '("out" "debug"))
(synopsis "Foreign function call interface library")
(description

View file

@ -0,0 +1,58 @@
From de93adfb6f48100946bba2c3abad2a77a0cfde0b Mon Sep 17 00:00:00 2001
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Date: Sun, 24 Nov 2019 09:52:01 +0100
Subject: [PATCH] ffi_powerpc.h: fix build failure with powerpc7
This is a patch pulled down from the following:
https://github.com/buildroot/buildroot/blob/78926f610b1411b03464152472fd430012deb9ac/package/libffi/0004-ffi_powerpc.h-fix-build-failure-with-powerpc7.patch
This issue is being hit on OpenBMC code when pulling the latest
libffi tag and building on a P8 ppc64le machine. I verified this
patch fixes the issue we are seeing.
Below is the original commit message:
Sicne commit 73dd43afc8a447ba98ea02e9aad4c6898dc77fb0, build on powerpc7
fails on:
In file included from ../src/powerpc/ffi.c:33:0:
../src/powerpc/ffi_powerpc.h:61:9: error: '_Float128' is not supported on this target
typedef _Float128 float128;
^~~~~~~~~
Fix this build failure by checking for __HAVE_FLOAT128 before using
_Float128, as _Float128 is enabled only on specific conditions, see
output/host/powerpc64-buildroot-linux-gnu/sysroot/usr/include/bits/floatn.h:
/* Defined to 1 if the current compiler invocation provides a
floating-point type with the IEEE 754 binary128 format, and this glibc
includes corresponding *f128 interfaces for it. */
#if defined _ARCH_PWR8 && defined __LITTLE_ENDIAN__ && (_CALL_ELF == 2) \
&& defined __FLOAT128__ && !defined __NO_LONG_DOUBLE_MATH
# define __HAVE_FLOAT128 1
#else
# define __HAVE_FLOAT128 0
#endif
Fixes:
- http://autobuild.buildroot.org/results/5c9dd8fb3b6a128882b6250f197c80232d8a3b53
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
---
src/powerpc/ffi_powerpc.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/powerpc/ffi_powerpc.h b/src/powerpc/ffi_powerpc.h
index 8e2f2f0e..960a5c42 100644
--- a/src/powerpc/ffi_powerpc.h
+++ b/src/powerpc/ffi_powerpc.h
@@ -57,7 +57,7 @@ typedef union
double d;
} ffi_dblfl;
-#if defined(__FLOAT128_TYPE__)
+#if defined(__FLOAT128_TYPE__) && defined(__HAVE_FLOAT128)
typedef _Float128 float128;
#elif defined(__FLOAT128__)
typedef __float128 float128;