gnu: gsl: Update to 2.6.
* gnu/packages/maths.scm (gsl): Update to 2.6. [source]: Remove patch. * gnu/packages/patches/gsl-test-i686.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
parent
ba6008760a
commit
7ad3c81240
3 changed files with 2 additions and 21 deletions
|
@ -938,7 +938,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/grep-timing-sensitive-test.patch \
|
||||
%D%/packages/patches/groovy-add-exceptionutilsgenerator.patch \
|
||||
%D%/packages/patches/grub-efi-fat-serial-number.patch \
|
||||
%D%/packages/patches/gsl-test-i686.patch \
|
||||
%D%/packages/patches/gspell-dash-test.patch \
|
||||
%D%/packages/patches/guile-1.8-cpp-4.5.patch \
|
||||
%D%/packages/patches/guile-2.2-default-utf8.patch \
|
||||
|
|
|
@ -375,15 +375,14 @@ (define-public dionysus
|
|||
(define-public gsl
|
||||
(package
|
||||
(name "gsl")
|
||||
(version "2.5")
|
||||
(version "2.6")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "mirror://gnu/gsl/gsl-"
|
||||
version ".tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"1395y9hlhqadn5g9j8q22224fds5sd92jxi9czfavjj24myasq04"))
|
||||
(patches (search-patches "gsl-test-i686.patch"))))
|
||||
"1a460zj9xmbgvcymkdhqh313c4l29mn9cffbi5vf33x3qygk70mp"))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
`(;; Currently there are numerous tests that fail on "exotic"
|
||||
|
|
|
@ -1,17 +0,0 @@
|
|||
Work around a test failure due to a rounding issue on 32-bit
|
||||
platforms, as reported at:
|
||||
|
||||
https://lists.gnu.org/archive/html/bug-gsl/2016-10/msg00000.html
|
||||
|
||||
--- gsl-2.2.1/linalg/test.c 2016-10-05 13:27:42.464059730 +0200
|
||||
+++ gsl-2.2.1/linalg/test.c 2016-10-05 13:27:46.988095882 +0200
|
||||
@@ -4843,9 +4843,6 @@ main(void)
|
||||
gsl_test(test_cholesky_decomp_unit(), "Cholesky Decomposition [unit triangular]");
|
||||
gsl_test(test_cholesky_solve(), "Cholesky Solve");
|
||||
|
||||
- gsl_test(test_cholesky_decomp(r), "Cholesky Decomposition");
|
||||
- gsl_test(test_cholesky_invert(r), "Cholesky Inverse");
|
||||
- gsl_test(test_pcholesky_decomp(r), "Pivoted Cholesky Decomposition");
|
||||
gsl_test(test_pcholesky_solve(r), "Pivoted Cholesky Solve");
|
||||
gsl_test(test_pcholesky_invert(r), "Pivoted Cholesky Inverse");
|
||||
gsl_test(test_mcholesky_decomp(r), "Modified Cholesky Decomposition");
|
Loading…
Reference in a new issue