gnu: linbox: Fix linking of dependant packages.

* gnu/packages/algebra.scm (linbox)[source]: Add a patch.
  [inputs]: Move fflas-ffpack to...
  [propagated-inputs]: ...here.
* gnu/packages/patches/linbox-fix-pkgconfig.patch: New file.
* gnu/local.mk (dist_patch_DATA): Register it.
This commit is contained in:
Jakub Kądziołka 2020-06-16 21:08:20 +02:00
parent 417eaa88dc
commit 781d03f135
No known key found for this signature in database
GPG key ID: E315A75846131564
3 changed files with 27 additions and 2 deletions

View file

@ -1236,6 +1236,7 @@ dist_patch_DATA = \
%D%/packages/patches/lierolibre-newer-libconfig.patch \
%D%/packages/patches/lierolibre-remove-arch-warning.patch \
%D%/packages/patches/lierolibre-try-building-other-arch.patch \
%D%/packages/patches/linbox-fix-pkgconfig.patch \
%D%/packages/patches/linkchecker-tests-require-network.patch \
%D%/packages/patches/linphoneqt-tabbutton.patch \
%D%/packages/patches/linux-libre-fix-atheros-9271.patch \

View file

@ -1365,14 +1365,15 @@ (define-public linbox
(file-name (git-file-name name version))
(sha256
(base32
"10j6dspbsq7d2l4q3y0c1l1xwmaqqba2fxg59q5bhgk9h5d7q571"))))
"10j6dspbsq7d2l4q3y0c1l1xwmaqqba2fxg59q5bhgk9h5d7q571"))
(patches (search-patches "linbox-fix-pkgconfig.patch"))))
(build-system gnu-build-system)
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)
("libtool" ,libtool)
("pkg-config" ,pkg-config)))
(inputs
(propagated-inputs
`(("fflas-ffpack" ,fflas-ffpack)))
(synopsis "C++ library for linear algebra over exact rings")
(description

View file

@ -0,0 +1,23 @@
Backported from:
From 426eb97ba762c7663884f57ead0909f2aa3cd6a5 Mon Sep 17 00:00:00 2001
From: Cyril Bouvier <cyril.bouvier@lirmm.fr>
Date: Thu, 17 Jan 2019 16:32:19 +0100
Subject: [PATCH] Remove @LINBOXSAGE_LIBS@ from linbox.pc.in
---
linbox.pc.in | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/linbox.pc.in b/linbox.pc.in
index 278f127e4..c6b8091eb 100644
--- a/linbox.pc.in
+++ b/linbox.pc.in
@@ -9,6 +9,6 @@ Description: Exact Linear Algebra library
URL: http://github.com/linbox-team/linbox
Version: @VERSION@
Requires: fflas-ffpack >= 2.4.0, givaro >= 4.1.0
-Libs: -L${libdir} -llinbox @LINBOXSAGE_LIBS@ @NTL_LIBS@ @MPFR_LIBS@ @FPLLL_LIBS@ @IML_LIBS@ @FLINT_LIBS@ @OCL_LIBS@
+Libs: -L${libdir} -llinbox @NTL_LIBS@ @MPFR_LIBS@ @FPLLL_LIBS@ @IML_LIBS@ @FLINT_LIBS@ @OCL_LIBS@
Cflags: @DEFAULT_CFLAGS@ -DDISABLE_COMMENTATOR -I${includedir} @NTL_CFLAGS@ @MPFR_CFLAGS@ @FPLLL_CFLAGS@ @IML_CFLAGS@ @FLINT_CFLAGS@
\-------------------------------------------------------