gnu: qt-4: Disable webkit build.

* gnu/packages/qt.scm (qt-4)[source]: Add snippet to remove the webkit code
  and drop one patch used previously for webkit.
  [arguments]: Add configure flag to disable building the webkit module.
* gnu/packages/patches/qt4-tests.patch: Delete file.
* gnu-system.am (dist_patch_DATA): Unregister patch.

Partially fixes <http://bugs.gnu.org/21288>.
This commit is contained in:
Andreas Enge 2015-10-04 00:51:21 +02:00
parent f8822418f1
commit 7431edea5b
3 changed files with 8 additions and 24 deletions

View file

@ -611,7 +611,6 @@ dist_patch_DATA = \
gnu/packages/patches/python2-pygobject-2-gi-info-type-error-domain.patch \
gnu/packages/patches/qemu-CVE-2015-6855.patch \
gnu/packages/patches/qt4-ldflags.patch \
gnu/packages/patches/qt4-tests.patch \
gnu/packages/patches/qt5-runpath.patch \
gnu/packages/patches/ratpoison-shell.patch \
gnu/packages/patches/readline-link-ncurses.patch \

View file

@ -1,22 +0,0 @@
Drop tests requiring a running X server, but not starting any.
diff -ru qt-everywhere-opensource-src-4.8.5.orig/src/3rdparty/webkit/Source/WebKit/qt/tests/tests.pro qt-everywhere-opensource-src-4.8.5/src/3rdparty/webkit/Source/WebKit/qt/tests/tests.pro
--- qt-everywhere-opensource-src-4.8.5.orig/src/3rdparty/webkit/Source/WebKit/qt/tests/tests.pro 2013-10-12 13:15:47.000000000 +0200
+++ qt-everywhere-opensource-src-4.8.5/src/3rdparty/webkit/Source/WebKit/qt/tests/tests.pro 2013-10-12 13:20:15.000000000 +0200
@@ -1,15 +1,4 @@
TEMPLATE = subdirs
-SUBDIRS = qwebframe qwebpage qwebelement qgraphicswebview qwebhistoryinterface qwebview qwebhistory qwebinspector hybridPixmap
+SUBDIRS =
-linux-* {
- # This test bypasses the library and links the tested code's object itself.
- # This stresses the build system in some corners so we only run it on linux.
- SUBDIRS += MIMESniffing
-}
-
-contains(QT_CONFIG, declarative): SUBDIRS += qdeclarativewebview
-SUBDIRS += benchmarks/painting benchmarks/loading
-contains(DEFINES, ENABLE_WEBGL=1) {
- SUBDIRS += benchmarks/webgl
-}

View file

@ -243,7 +243,11 @@ (define-public qt-4
(base32
"183fca7n7439nlhxyg1z7aky0izgbyll3iwakw4gwivy16aj5272"))
(patches (map search-patch
'("qt4-ldflags.patch" "qt4-tests.patch")))))
'("qt4-ldflags.patch")))
(modules '((guix build utils)))
(snippet
;; Remove webkit module, which is not built.
'(delete-file-recursively "src/3rdparty/webkit"))))
(inputs `(,@(alist-delete "harfbuzz"
(alist-delete "libjpeg" (package-inputs qt)))
("libjepg" ,libjpeg-8)
@ -288,6 +292,9 @@ (define-public qt-4
"-confirm-license"
;; explicitly link with dbus instead of dlopening it
"-dbus-linked"
;; Skip the webkit module; it fails to build on armhf
;; and, apart from that, may pose security risks.
"-no-webkit"
;; drop special machine instructions not supported
;; on all instances of the target
,@(if (string-prefix? "x86_64"