gnu: ganeti: Prepare for Sphinx 4.0.
* gnu/packages/patches/ganeti-sphinx-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/virtualization.scm (ganeti)[source](patches): Add it.
This commit is contained in:
parent
393315a98e
commit
711ee48f81
3 changed files with 26 additions and 0 deletions
|
@ -1068,6 +1068,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/ganeti-preserve-PYTHONPATH.patch \
|
||||
%D%/packages/patches/ganeti-shepherd-master-failover.patch \
|
||||
%D%/packages/patches/ganeti-shepherd-support.patch \
|
||||
%D%/packages/patches/ganeti-sphinx-compat.patch \
|
||||
%D%/packages/patches/gash-utils-ls-test.patch \
|
||||
%D%/packages/patches/gawk-shell.patch \
|
||||
%D%/packages/patches/gcc-arm-bug-71399.patch \
|
||||
|
|
24
gnu/packages/patches/ganeti-sphinx-compat.patch
Normal file
24
gnu/packages/patches/ganeti-sphinx-compat.patch
Normal file
|
@ -0,0 +1,24 @@
|
|||
Adjust documentation for Sphinx 4.0.
|
||||
|
||||
Discussed upstream at <https://github.com/ganeti/ganeti/pull/1615>.
|
||||
|
||||
diff --git a/doc/index.rst b/doc/index.rst
|
||||
--- a/doc/index.rst
|
||||
+++ b/doc/index.rst
|
||||
@@ -119,7 +119,6 @@ Draft designs
|
||||
design-hotplug.rst
|
||||
design-internal-shutdown.rst
|
||||
design-kvmd.rst
|
||||
- design-location.rst
|
||||
design-linuxha.rst
|
||||
design-location.rst
|
||||
design-lu-generated-jobs.rst
|
||||
diff --git a/lib/build/shell_example_lexer.py b/lib/build/shell_example_lexer.py
|
||||
--- a/lib/build/shell_example_lexer.py
|
||||
+++ b/lib/build/shell_example_lexer.py
|
||||
@@ -79,4 +79,4 @@ class ShellExampleLexer(RegexLexer):
|
||||
|
||||
|
||||
def setup(app):
|
||||
- app.add_lexer("shell-example", ShellExampleLexer())
|
||||
+ app.add_lexer("shell-example", ShellExampleLexer)
|
|
@ -519,6 +519,7 @@ (define-public ganeti
|
|||
(file-name (git-file-name name version))
|
||||
(patches (search-patches "ganeti-shepherd-support.patch"
|
||||
"ganeti-shepherd-master-failover.patch"
|
||||
"ganeti-sphinx-compat.patch"
|
||||
"ganeti-haskell-compat.patch"
|
||||
"ganeti-haskell-pythondir.patch"
|
||||
"ganeti-disable-version-symlinks.patch"
|
||||
|
|
Loading…
Reference in a new issue