gnu: python-unittest2: Adjust patch for Python 3.10 compatibility.

* gnu/packages/patches/python-unittest2-python3-compat.patch: Add hunk
for Python 3.10 compatibility.
This commit is contained in:
Ludovic Courtès 2023-04-20 16:42:09 +02:00
parent c7d6fe2792
commit 6d32421f6e
No known key found for this signature in database
GPG key ID: 090B11993D9AEBB5

View file

@ -32,3 +32,15 @@ index 683f662..347eea5 100644
def test_loadTestsFromNames__relative_malformed_name(self):
loader = unittest.TestLoader()
diff --git a/unittest2/compatibility.py b/unittest2/compatibility.py
index 9e5f1a5..2d20c19 100644
--- a/unittest2/compatibility.py
+++ b/unittest2/compatibility.py
@@ -140,6 +140,6 @@ except ImportError:
### ChainMap (helper for configparser and string.Template)
########################################################################
-class ChainMap(collections.MutableMapping):
+class ChainMap(collections.abc.MutableMapping):
''' A ChainMap groups multiple dicts (or other mappings) together
to create a single, updateable view.