gnu: mrustc: Update to 0.8.1.

* gnu/packages/patches/mrustc-0.8.0-fix-variable-length-integer-receiving.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
* gnu/packages/rust.scm (mrustc): Update to 0.8.1.
[source](patches): Remove it.
[native-inputs]: Add zlib.
This commit is contained in:
Danny Milosavljevic 2020-01-21 16:44:18 +01:00
parent c450ee9755
commit 6839095af7
No known key found for this signature in database
GPG key ID: E71A35542C30BAA5
3 changed files with 4 additions and 21 deletions

View file

@ -1180,7 +1180,6 @@ dist_patch_DATA = \
%D%/packages/patches/mozjs38-tracelogger.patch \
%D%/packages/patches/mozjs38-version-detection.patch \
%D%/packages/patches/mrrescue-support-love-11.patch \
%D%/packages/patches/mrustc-0.8.0-fix-variable-length-integer-receiving.patch \
%D%/packages/patches/mtools-mformat-uninitialized.patch \
%D%/packages/patches/mumps-build-parallelism.patch \
%D%/packages/patches/mumps-shared-libseq.patch \

View file

@ -1,15 +0,0 @@
https://github.com/thepowersgang/mrustc/issues/109
From: Danny Milosavljevic <dannym@scratchpost.org>
Date: Fri, 3 Jan 2019 13:00:00 +0100
--- mrustc/src/expand/proc_macro.cpp.orig 2019-02-01 14:16:54.208486062 +0100
+++ mrustc/src/expand/proc_macro.cpp 2019-02-01 14:17:14.350925705 +0100
@@ -977,7 +977,7 @@
for(;;)
{
auto b = recv_u8();
- v |= static_cast<uint64_t>(b) << ofs;
+ v |= static_cast<uint64_t>(b & 0x7F) << ofs;
if( (b & 0x80) == 0 )
break;
ofs += 7;

View file

@ -91,7 +91,7 @@ (define-public mrustc
(let ((rustc-version "1.19.0"))
(package
(name "mrustc")
(version "0.8.0")
(version "0.8.1")
(source (origin
(method git-fetch)
(uri (git-reference
@ -100,9 +100,7 @@ (define-public mrustc
(file-name (git-file-name name version))
(sha256
(base32
"0a7v8ccyzp1sdkwni8h1698hxpfz2sxhcpx42n6l2pbm0rbjp08i"))
(patches
(search-patches "mrustc-0.8.0-fix-variable-length-integer-receiving.patch"))))
"00800zckq009kf9v3hb8kp1svryvq3jpg4439ksm3wcidjvszdzc"))))
(outputs '("out" "cargo"))
(build-system gnu-build-system)
(inputs
@ -111,7 +109,8 @@ (define-public mrustc
`(("bison" ,bison)
("flex" ,flex)
;; Required for the libstd sources.
("rustc" ,(package-source rust-1.19))))
("rustc" ,(package-source rust-1.19))
("zlib" ,zlib)))
(arguments
`(#:test-target "local_tests"
#:make-flags (list (string-append "LLVM_CONFIG="