gnu: Remove python-pyflakes-2.2.

* gnu/packages/python-xyz.scm (python-pyflakes-2.2): Delete variable.
* gnu/packages/patches/python-pyflakes-test-location.patch: Remove file.
* gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
Efraim Flashner 2023-09-08 10:01:02 +03:00
parent 7525396c1e
commit 67ffb90dcb
No known key found for this signature in database
GPG key ID: 41AAE7DCCA3D8351
3 changed files with 0 additions and 56 deletions

View file

@ -1835,7 +1835,6 @@ dist_patch_DATA = \
%D%/packages/patches/python-piexif-fix-tests-with-pillow-7.2.patch \
%D%/packages/patches/python-pillow-CVE-2022-45199.patch \
%D%/packages/patches/python-pyfakefs-remove-bad-test.patch \
%D%/packages/patches/python-pyflakes-test-location.patch \
%D%/packages/patches/python-flint-includes.patch \
%D%/packages/patches/python-libxml2-utf8.patch \
%D%/packages/patches/python-memcached-syntax-warnings.patch \

View file

@ -1,42 +0,0 @@
This patch fixes test failure related to reported source code locations.
It is a backport of this patch:
commit 6a5f38b5ab12260fde8a0463acd433bc2d34dbcf
Author: Louis Sautier <sautier.louis@gmail.com>
Date: Sat Oct 3 02:37:53 2020 +0200
Fix tests with Python 3.9, closes #549 (#586)
Stop allowing failures on Python nightly.
diff --git a/pyflakes/test/test_api.py b/pyflakes/test/test_api.py
index 128aa69..b728e65 100644
--- a/pyflakes/test/test_api.py
+++ b/pyflakes/test/test_api.py
@@ -515,6 +515,8 @@ def foo(bar=baz, bax):
if ERROR_HAS_LAST_LINE:
if PYPY and sys.version_info >= (3,):
column = 7
+ elif sys.version_info >= (3, 9):
+ column = 21
elif sys.version_info >= (3, 8):
column = 9
else:
@@ -543,6 +545,8 @@ foo(bar=baz, bax)
if ERROR_HAS_LAST_LINE:
if PYPY and sys.version_info >= (3,):
column = 12
+ elif sys.version_info >= (3, 9):
+ column = 17
elif sys.version_info >= (3, 8):
column = 14
else:
@@ -577,6 +581,8 @@ foo(bar=baz, bax)
position_end = 1
if PYPY:
column = 6
+ elif ver >= (3, 9):
+ column = 13
else:
column = 7
# Column has been "fixed" since 3.2.4 and 3.3.1

View file

@ -12493,19 +12493,6 @@ (define-public python-pyflakes
"Pyflakes statically checks Python source code for common errors.")
(license license:expat)))
(define-public python-pyflakes-2.2
(package
(inherit python-pyflakes)
(version "2.2.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "pyflakes" version))
(sha256
(base32
"1j3zqbiwkyicvww499bblq33x0bjpzdrxajhaysr7sk7x5gdgcim"))
(patches
(search-patches "python-pyflakes-test-location.patch"))))))
(define-public python-mccabe
(package
(name "python-mccabe")