gnu: dezyne: Add patch to avoid "Exec format error".

This fixes

    In execvp of ./test/all/parse_import_order/run: Exec format error

on shell scripts that lack a shebang.

* gnu/packages/patches/dezyne-add-missing-shebangs.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/dezyne.scm (dezyne): Use it.
This commit is contained in:
Janneke Nieuwenhuizen 2023-04-24 20:54:31 +02:00
parent c7cdd4a6c7
commit 5eb1d1b648
No known key found for this signature in database
GPG key ID: F3C1A0D9C1D65273
3 changed files with 64 additions and 0 deletions

View file

@ -1049,6 +1049,7 @@ dist_patch_DATA = \
%D%/packages/patches/dee-vapi.patch \
%D%/packages/patches/desmume-gcc6-fixes.patch \
%D%/packages/patches/desmume-gcc7-fixes.patch \
%D%/packages/patches/dezyne-add-missing-shebangs.patch \
%D%/packages/patches/dfu-programmer-fix-libusb.patch \
%D%/packages/patches/diffutils-fix-signal-processing.patch \
%D%/packages/patches/dkimproxy-add-ipv6-support.patch \

View file

@ -22,6 +22,7 @@ (define-module (gnu packages dezyne)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix gexp)
#:use-module (guix packages)
#:use-module (gnu packages)
#:use-module (gnu packages base)
#:use-module (gnu packages bash)
#:use-module (gnu packages guile)
@ -37,6 +38,7 @@ (define-public dezyne
(method url-fetch)
(uri (string-append "https://dezyne.org/download/dezyne/"
name "-" version ".tar.gz"))
(patches (search-patches "dezyne-add-missing-shebangs.patch"))
(sha256
(base32 "1v0anwr0iic26ck796b29dfyj1dxkjf935g134z98s95hvzzrhm3"))))
(inputs (list bash-minimal

View file

@ -0,0 +1,61 @@
Upstream status: Taken from upstream development.
From aace425e41247c1dd6b16eb7eabce50be7310d15 Mon Sep 17 00:00:00 2001
From: Janneke Nieuwenhuizen <janneke@gnu.org>
Date: Mon, 24 Apr 2023 16:58:32 +0200
Subject: [PATCH] DRAFT test: Add missing shebangs to run scripts.
This fixes `make check' on current ci.guix.gnu.org.
* test/all/parse_import_order/run,
test/all/parse_locations/run,
test/all/parse_peg_locations/run: Add #! /bin/sh.
---
test/all/parse_import_order/run | 3 ++-
test/all/parse_locations/run | 3 ++-
test/all/parse_peg_locations/run | 3 ++-
3 files changed, 6 insertions(+), 3 deletions(-)
diff --git a/test/all/parse_import_order/run b/test/all/parse_import_order/run
index 6e231de4f9..c383e4f223 100755
--- a/test/all/parse_import_order/run
+++ b/test/all/parse_import_order/run
@@ -1,6 +1,7 @@
+#! /bin/sh
# Dezyne --- Dezyne command line tools
#
-# Copyright © 2022 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
+# Copyright © 2022, 2023 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
#
# This file is part of Dezyne.
#
diff --git a/test/all/parse_locations/run b/test/all/parse_locations/run
index 0b092b26dd..6c48ee1392 100755
--- a/test/all/parse_locations/run
+++ b/test/all/parse_locations/run
@@ -1,7 +1,8 @@
+#! /bin/sh
# Dezyne --- Dezyne command line tools
#
# Copyright © 2021 Paul Hoogendijk <paul@dezyne.org>
-# Copyright © 2020, 2021 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
+# Copyright © 2020, 2021, 2023 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
#
# This file is part of Dezyne.
#
diff --git a/test/all/parse_peg_locations/run b/test/all/parse_peg_locations/run
index 5b5ced0bb4..5206a23db6 100755
--- a/test/all/parse_peg_locations/run
+++ b/test/all/parse_peg_locations/run
@@ -1,6 +1,7 @@
+#! /bin/sh
# Dezyne --- Dezyne command line tools
#
-# Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
+# Copyright © 2020, 2023 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
#
# This file is part of Dezyne.
#
--
2.39.2