gnu: netsurf: Update to 3.10.

* gnu/packages/web.scm (netsurf): Update to 3.10.
* gnu/packages/patches/netsurf-system-utf8proc.patch: Adjust to new source.
This commit is contained in:
Eric Bavier 2020-05-26 14:50:10 -05:00
parent 981d80b331
commit 5c133ca561
No known key found for this signature in database
GPG key ID: FD73CAC719D32566
2 changed files with 9 additions and 46 deletions

View file

@ -1,50 +1,13 @@
Use upstream utf8proc package, as suggested in
http://source.netsurf-browser.org/libutf8proc.git/commit/?id=770e329cceaf0620c7b482589a9b17ed1d19c16d
Fix include directory for system utf8proc.
Work around upstream's lack of a pkg-config file and update API.
--- netsurf-3.6/Makefile
+++ netsurf-3.6/Makefile
@@ -527,10 +527,9 @@
$(eval $(call pkg_config_find_and_add,libcss,CSS))
$(eval $(call pkg_config_find_and_add,libdom,DOM))
$(eval $(call pkg_config_find_and_add,libnsutils,nsutils))
-$(eval $(call pkg_config_find_and_add,libutf8proc,utf8proc))
--- netsurf-3.10/utils/idna.c
+++ netsurf-3.10/utils/idna.c
@@ -167,7 +167,7 @@
# Common libraries without pkg-config support
-LDFLAGS += -lz
+LDFLAGS += -lz -lutf8proc
#ifdef WITH_UTF8PROC
# Optional libraries with pkgconfig
--- netsurf-3.8/utils/idna.c
+++ netsurf-3.8/utils/idna.c
@@ -27,7 +27,7 @@
#include <stdlib.h>
#include <string.h>
#include <sys/types.h>
-#include <libutf8proc/utf8proc.h>
+#include <utf8proc.h>
#include "netsurf/inttypes.h"
--- netsurf-3.8/test/Makefile
+++ netsurf-3.8/test/Makefile
@@ -142,14 +142,15 @@
-Itest -Iinclude -Icontent/handlers -Ifrontends -I. -I.. \
-Dnsgtk \
$(SAN_FLAGS) \
- $(shell pkg-config --cflags libcurl libparserutils libwapcaplet libdom libnsutils libutf8proc) \
+ $(shell pkg-config --cflags libcurl libparserutils libwapcaplet libdom libnsutils) \
$(LIB_CFLAGS)
TESTCFLAGS := $(BASE_TESTCFLAGS) \
$(COV_CFLAGS) \
$(COV_CPPFLAGS)
TESTLDFLAGS := -L$(TESTROOT) \
- $(shell pkg-config --libs libcurl libparserutils libwapcaplet libdom libnsutils libutf8proc) -lz \
+ $(shell pkg-config --libs libcurl libparserutils libwapcaplet libdom libnsutils) \
+ $(LDFLAGS) \
$(SAN_FLAGS) \
$(LIB_LDFLAGS)\
$(COV_LDFLAGS)
int32_t idna_contexto[] = {
/* CONTEXTO codepoints which have a rule defined */

View file

@ -5247,7 +5247,7 @@ (define-public nsgenbind
(define-public netsurf
(package
(name "netsurf")
(version "3.9")
(version "3.10")
(source
(origin
(method url-fetch)
@ -5255,7 +5255,7 @@ (define-public netsurf
"releases/source/netsurf-" version "-src.tar.gz"))
(sha256
(base32
"1hzcm2s2wh5sapgr000lg63hcdbj6hyajxl43xa1x80kc5piqbyp"))
"0plra64c5xyiw12yx2q13brxsv8apmany97zqa2lcqckw4ll8j1n"))
(patches (search-patches "netsurf-system-utf8proc.patch"
"netsurf-y2038-tests.patch"
"netsurf-longer-test-timeout.patch"