gnu: higan: Update to 106.

* gnu/packages/games.scm (higan): Update to 106.
* gnu/packages/patches/higan-remove-march-native-flag.patch: Adjust.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
This commit is contained in:
Rutger Helling 2017-11-22 09:32:25 +01:00 committed by Ludovic Courtès
parent 327620dc72
commit 5864f1c1ee
No known key found for this signature in database
GPG key ID: 090B11993D9AEBB5
2 changed files with 9 additions and 10 deletions

View file

@ -3035,7 +3035,7 @@ (define-public red-eclipse
(define-public higan
(package
(name "higan")
(version "104")
(version "106")
(source
(origin
(method url-fetch)
@ -3044,7 +3044,7 @@ (define-public higan
version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32 "18by01ir2mvdi9hq571in1hk18gw2bd0ynq4avfs1qj0qra35fqb"))
(base32 "0y42pra0dxzlbkyzcp3r8a39pji2bj3p9fl40425f60af2igr4rw"))
(patches (search-patches "higan-remove-march-native-flag.patch"))))
(build-system gnu-build-system)
(native-inputs

View file

@ -2,12 +2,11 @@ Remove -march=native from build flags.
--- a/higan/GNUmakefile
+++ b/higan/GNUmakefile
@@ -32,7 +32,7 @@ ifeq ($(platform),windows)
else ifeq ($(platform),macosx)
flags += -march=native
else ifneq ($(filter $(platform),linux bsd),)
- flags += -march=native -fopenmp
+ flags += -fopenmp
@@ -26,7 +26,6 @@
flags += -fopenmp
link += -fopenmp
link += -Wl,-export-dynamic
link += -lX11 -lXext
ifeq ($(binary),application)
- flags += -march=native
link += -Wl,-export-dynamic
link += -lX11 -lXext
else ifeq ($(binary),library)